PSU Repair: A Case Study

Auxiliary Output Capacitor Replacement

Time to hit the spare parts bin again. The nearest match I have for a 47µF 25V cap is 100µF 50V Panasonic FC-series. As with the FM on the 5VSB output, the footprints and lead spacings do not match. At least this time there is plenty of clearance, so I don't need to shove things around to accommodate the larger package. I will still put something with the proper lead spacing on my next order so I can have a properly-mounted cap as my definitive fix. For troubleshooting purposes though, this is fine--a bodged cap with long leads is still better than a dead cap or no cap at all.

Here you can see the old cap and my replacement part; the size discrepancy is hardly subtle. When I measured that 47µF cap, it read 112pF. Yes, that's picofarads, five orders of magnitude off. The bond between the leads and the capacitor's foils or the foils themselves must have broken, corroded, fused off or something else of the sort. In any case, the capacitor reads open on the ohms range, so no internal short here either. Dead caps don't come much deader than that.

Looking at the auxiliary and PWM off-state waveforms in the first picture, I think it is quite blatantly obvious something changed. The massive noise and ripples on the auxiliary output are almost completely gone. Eliminating the auxiliary supply's massive transients also took care of those glitches on the switching controller's bypass capacitor, allowing its off-state voltage to drop lower as well.

On the second picture, signs of completely different PS_ON# behavior on the auxiliary and PWM supplies are hard to miss. Instead of 20VPP worth of ripple with a lazy transition to 10VDC, we have a steady 20VDC or so on the auxiliary supply with the PWM's supply going through a sharp rise to 20V when PS_ON# comes through. There is still some amount of switching noise on the waveforms, but it is about an order of magnitude less than it was before. That's possibly better, but hard to tell at this resolution.

The last picture shows the steady on-state at a higher-resolution time scale. Whereas the old cap waveforms showed random-looking signals that had no clear relationship with the reference voltage, the auxiliary and PWM voltages are now a steady 20V above bottom cap voltage, exactly as one would expect from a capacitor charged to a certain voltage above the node it is referenced to.

With 20V DC on it during normal operation (not counting switching transients and possible output deviations), the original capacitor really should have been a 35V part, which might explain why it failed so thoroughly. Aside from that, things look very promising. This certainly looks like a major step towards a permanent fix.

Look 'ma, no shunt regulator required anymore! The 8V power-up overshoot is gone, replaced by a far more reasonable 5.4V. That's within ATX's 10% turn-on transient specification. After that, the 5VSB output settles down to 5.2V on its own.

The main outputs' ramp-up also looks as good as it is ever going to be. This is smelling like a definitive fix in the making. All the hissing during turn-on is gone as well.