Solved

Tried everything, Display still doesn't show.

Monitor is not reading my PC input, I have cleaned my RAM, Checked all the cables, rebooted the PC and the monitor and even used a different monitor. There is no signal reading on both monitors. Does not even flash my PC screen, just acts as if nothing was plugged in.
17 answers Last reply Best Answer
More about display show
  1. Best answer
    your motherboard have a onboard video chipset remove gpu and try to plug monitor to it for video .
  2. scout_03 said:
    your motherboard have a onboard video chipset remove gpu and try to plug monitor to it for video .


    Is there a port for HDMI/VGA in the actual PC, I'm looking at my motherboard right now, not sure where the chip set is
  3. name and model of board .
  4. scout_03 said:
    name and model of board .


    ASRock H97 Anniversary
  5. use the dvi-d connector on the back also does your intel cpu have onboard video chipset check this .
  6. scout_03 said:
    use the dvi-d connector on the back also does your intel cpu have onboard video chipset check this .


    removing the gpu right now, will check
  7. scout_03 said:
    use the dvi-d connector on the back also does your intel cpu have onboard video chipset check this .


    Okay GPU is removed, I see some ports on the bottom right of my motherboard but not really anything by my intel cpu
  8. connect monitor to dvi-d and boot system to see if you have video on it .
  9. scout_03 said:
    connect monitor to dvi-d and boot system to see if you have video on it .


    I currently do not have a dvi-d cable, is there any alternative?
  10. the d-sub or hdmi .
  11. scout_03 said:
    the d-sub or hdmi .


    Is there an HDMI port on the motherboard? There is one on the outside which I have been using in the past, but like I said, the monitor still won pick up that signal
  12. could it be that your hdmi cable is broke see if you could borrow one .
  13. scout_03 said:
    could it be that your hdmi cable is broke see if you could borrow one .


    Okay something interesting happened, the monitor gets the signal when I remove the GPU but it cant read my PC after I put it back in
  14. have the gpu test in another sytem to see if you have same issue also you could use a old gpu to test signal to monitor .
  15. scout_03 said:
    have the gpu test in another sytem to see if you have same issue also you could use a old gpu to test signal to monitor .


    reset the monitor and plugged into the GPU slot, everything seems to be working now! Thank you so much for your help!
  16. could it be that the gpu was not well seated in board slot and back screw holding it was not on .
  17. scout_03 said:
    could it be that the gpu was not well seated in board slot and back screw holding it was not on .


    Maybe, but wouldn't have thought it was my GPU if you didn't let me know to take it out, thank you! Been trying to troubleshoot this for the past 2 hours!
Ask a new question

Read More

VGA Monitors HDMI Displays