Solved

Device not bootable in legacy mode, and not showing up in uefi mode.

Hello,
I was removing ssd from my PC to my brothers PC and when I wanted to boot my PC with another m.2 ssd with Windows 10 I had in my PC it booted just to bios. Then I discovered that when in boot mode there is no device to boot. So I tried legacy mode and there it show all my 3 drives but when booting into one with windows it says reboot "reboot and select proper boot device or insert boot media in selected boot device and press a key".

Any idea what is wrong. When I had both of ssd installed I was choosing at the start from windows manager. I have tried different bios setting with secure boot etc..
Now I launched windows memory diagnostic tool from Q10 USB stick in uefi boot mode. I am at 4%.

Any idea what is wrong with it?
Reply to Ediksto
6 answers Last reply Best Answer
More about device bootable legacy mode showing uefi mode
  1. If OS on your boot device is installed in UEFI mode, you can boot it only in UEFI mode.
    Same goes for legacy mode.

    And it is not a appropriate to use OS installed on another PC, because of:
    boot mode compatibility (what you're experiencing), driver issues, OS activation problems.

    Just reinstall OS.
    Reply to SkyNetRising
  2. I am not booting ssd from different PC. I had 2 ssd, both with windows but using the newer one to restore some some data from older ssd. Now that I removed the older one the newer one is not bootable.
    Reply to Ediksto
  3. Probably bootloader was located on the drive you removed.

    Put back all the drives,
    change BIOS to previous values,
    boot into windows and
    post screenshot from Disk Management.
    Reply to SkyNetRising
  4. Reply to Ediksto
  5. Best answer
    Well - see the partition with description "EFI system partition"?
    That's where bootloader lives. Without that drive connected, your system will not boot.

    1st - make sure your Disk 0 ( with partition C: ) is partitioned in GPT format. Look for Partition Style in disk properties.
    If Partition Style is MBR, you'll have to convert your drive to GPT before continuing.
    2. If all is well (GPT parition style), then shrink C: by 100 MB and create a new EFI system partition there and format it.
    3. Create bootloader in the new partition using bcdboot command.
    Reply to SkyNetRising
  6. You're right. It worked although I used this and it took me an hour to make it.
    Thanks.
    Reply to Ediksto
Ask a new question Answer

Read More

SSD Legacy Boot Devices