Solved

BIOS: Change back from Legacy to UEFI

While trying to fix a boot error (0xc0000034) on my laptop I accidentally changed my computer's BIOS from UEFI to Legacy, is there a way to change it back?

The computer is clean so it doesn't matter if it's a method that causes loss of data. I have a bootable USB with windows 10 (maybe 8) on it. At some point I got into the menu for this, but must of the times I just get straight to the BIOS. And when I got to the menu for installing windows, I got the error message "windows cannot be installed on this disk. The selected disk is of the GPT partition style." so I couldn't get past from there anyway

The computer is an MSI GE70 2QE

Here is what it says on the startup screen of the BIOS. The only options I have from here is either "Delete RAID volume" or "Reset Disks to Non-RAID" (none of which I know what it means)

Bios menu 1:
http://imgur.com/ykMreja

Bios info screen:
http://imgur.com/C2tP4ej


Would be very thankful for any help!
Reply to paperwhite
4 answers Last reply Best Answer
More about bios change back legacy uefi
  1. Change it back in the BIOS. The same way you changed it to legacy
    Reply to Paul NZ
  2. But since changing to Legacy, I can only see the screens that I attached, not Aptio setup utility where I changed it to Legacy in the first place?
    Reply to paperwhite
  3. Best answer
    Thats the post screen not in the bios itself. Reboot and press del or F2 / whatever key to get into the BIOS
    Reply to Paul NZ
  4. Thanks a lot, that worked! Now I'm back to my initial problem but I'll make a separate thread for that
    Reply to paperwhite
Ask a new question Answer

Read More

BIOS Computers Legacy