Bad FPS after Windows 10 Update (GTX 1070, i5 6600k)

So i built my first gaming pc yesterday, here are its specs:

i5 6600k (cooled by a BeQuiet! shadow rock slim)
16gb ddr4 Corsair Vengeance 3000mHz
MX 300 Crucial 525gb
PSU: EVGA 650 GS
Zotax GTX1070 Mini (was running Watch Dogs 2 maxed out below 65 degrees)
Asus z170i PRO gaming

The pc was going fast and strong till windows decided to update itself and screw eveything up. Now I only get like 20 FPS and everyhting has become unplayable. I noticed that windows installed the Intel graphics card driver in the last update and I suspect that this is causing conflict in the GPU usage. I tried 3 times uninstalling intel drivers with DDU and triple checked that i was doin no overclocking, selected the PCI-e as my default graphics in BIOS. Also there's no Intel graphics driver listed in the installed apps that i can uninstall.

This is the update name "Intel Corporation - Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2, Graphics Adapter WDDM1.3, Graphics Adapter WDDM2.0 - Intel(R) HD Graphics 530".

I am really desperate.
5 answers Last reply
More about bad fps windows update gtx 1070 6600k
  1. [EDIT] Re download the new Nvidia Drivers. The integrated Drivers should not have any affect on your discrete drivers.
  2. sarinaide said:
    [EDIT] Re download the new Nvidia Drivers. The integrated Drivers should not have any affect on your discrete drivers.


    Done that multiple times. I have been using the last Nvidia drivers (376.09)

    [EDIT] Trying to download the most recent drivers published today (376.19) with no success. The .exe file is corrupt and I get a Non 7zip archive error.
  3. You can try clear your update cache by typing disk cleanup then running win 10 Disk Clean, select to clean up system files and it will repeat the process, you can then remove all windows 10 stored updates.

    You can also run a group policy edit to turn off automatic updates by giving it a new mandate like Windows 7 to prompt you first before downloading/installing updates (Win + R) (GPEDIT.msc).

    As a long time user of Windows 7, I am not impressed with Windows 10 optimization, I think it is still very buggy and DX12 is all kinds of problems. Nvidia drivers don't seem as good as they should be and in general gaming on windows 10 is very erratic compared to windows 7.
  4. What windows update are you running, I think the latest is 14329 or something like that.

    1) check your device manager and under the video display adaptors, is it just displaying your GeForce card or both the GeForce and Intel, in which case there is a conflict, recheck your bios settings.

    2) Control Panel → Hardware & Sound → Power Options → Balanced Settings (Should be selected) → Change Plan Settings → Advanced Power Settings → Expand the processor management tab and look at your max processor state.

    Set your max load to 100% and minimum leave at 5%, some updates reset this to something like 80% usage which underperforms your power profile.
  5. sarinaide said:
    You can try clear your update cache by typing disk cleanup then running win 10 Disk Clean, select to clean up system files and it will repeat the process, you can then remove all windows 10 stored updates.

    You can also run a group policy edit to turn off automatic updates by giving it a new mandate like Windows 7 to prompt you first before downloading/installing updates (Win + R) (GPEDIT.msc).

    As a long time user of Windows 7, I am not impressed with Windows 10 optimization, I think it is still very buggy and DX12 is all kinds of problems. Nvidia drivers don't seem as good as they should be and in general gaming on windows 10 is very erratic compared to windows 7.



    sarinaide said:
    What windows update are you running, I think the latest is 14329 or something like that.

    1) check your device manager and under the video display adaptors, is it just displaying your GeForce card or both the GeForce and Intel, in which case there is a conflict, recheck your bios settings.

    2) Control Panel → Hardware & Sound → Power Options → Balanced Settings (Should be selected) → Change Plan Settings → Advanced Power Settings → Expand the processor management tab and look at your max processor state.

    Set your max load to 100% and minimum leave at 5%, some updates reset this to something like 80% usage which underperforms your power profile.


    Got Windows 10 PRO version 1607 build 14393.0

    In Device manager expanding the display adapter tab I can only see my GTX1070. Checked my power settings and they are good. Also tried with Disk cleanup with no success.
Ask a new question

Read More

Low FPS Windows Update CPUs Performance FPS Nvidia windows 10 GPUs Graphics Cards