Default Output Device Not Changing

I did a fresh install of windows 10 pro from windows 7 and I'm already starting to hate myself.

I open the playback devices tab under sound and click on my Siberia v2 illuminated headset and click set as default device and it does nothing. I can't disable my speakers or my headset. Extremely frustrating because I'm sure there's a simple solution surely.
3 answers Last reply
More about default output device changing
  1. I assume you have the right steelseries drivers, I have an old set and the newer drivers don't recognise them. Or my mouse

    What motherboard are you using? Does it have Realtek chip or Via? If Realtek, have you checked in their HD Audio Manager software, it may be a setting in there though its meant to work with the sound control panel.
  2. Colif said:
    I assume you have the right steelseries drivers, I have an old set and the newer drivers don't recognise them. Or my mouse

    What motherboard are you using? Does it have Realtek chip or Via? If Realtek, have you checked in their HD Audio Manager software, it may be a setting in there though its meant to work with the sound control panel.


    Steelseries drivers are not newly updated.

    I have an ASRock Fatal1ty 990FX Killer. Realtek HD Chip. I have checked their Audio Manager and using the set as default device option within that doesn't do anything as well.
  3. Update

    I tried reinstalling the Realtek Audio Drivers and now all of the options in the default play devices page don't work at all.
Ask a new question

Read More

Default windows 10 Windows 7 Devices Gaming Headsets