Trouble booting into Windows 10 after removing Linux

Hey everyone. Long time member, but my first time posting in years.

I've been running Windows 10 for a few months now. I decided to try out a dual-boot setup with Fedora Linux the other day. Partitioned the C drive and it went smoothly. I got Fedora installed, but apparently the latest version of Fedora has problems with Nvidia drivers or something, and after trying to troubleshoot, I decided to start over with a new distro. I booted back to Windows 10, went to disk management, and deleted the Linux partition (afterwards it appeared as unallocated space).

This is where I made my mistake. I didn't know you had to repair the Master Boot Record (MBR) after deleting a Linux partition. When I rebooted my computer, I could no longer boot into Windows. Regardless of what device I boot from (new Linux distro installation USB or drive with Windows 10 installed), I get the following "grub rescue" screen.

It is a black screen with this text on it:
..
error: disk \lvmid/F8MEu0-6pkZ-iYR3-zB0g-K1oz-VBTb-pRUzWx/cXd1Ka-Xv5f-25Ey-0G21-198Y-yxtJ-X7vxCU' not found.
Entering rescue mode...
grub rescue>

And you can input text here. Using the 'ls' command, which returns '(hd0) (hd0,msdos2) (hd0,msdos1)' when I unplug all but the drive I am trying to boot from (meaning only the SSD that was my C drive and Linux install drive is plugged in), it is clear that hd0 is the correct drive. the two other things must be its partitions. There was a 100MB Windows System Reserved (or something like that) partition, the main C drive partition (something like 60-70GB), and then the unallocated space.

I believe that the problem is that my computer is trying to boot into the partition that no longer exists. So the solution I tried was to make it boot into the C partition. I can't tell which partition it is, though. Using 'ls (hd0,msdos2)' returns '(hd0,msdos2): Filesystem is unknown', and the same happens for the other partition. In order to try and set the boot location back to this (taking the 50/50 shot at which partition was correct), I tried
set root=(hd0,msdos2)
and
set prefix=(hd0,msdos2)/boot/grub
. Both of these seem to run without error. Running 'insmod normal' to try it out returns 'error: unknown filesystem'.

So at this point, I can't boot from anything (including USB - I tried SuperGRUB2Disk) because of the boot error, and can't seem to point GRUB at a different partition than the one that no longer exists. Any ideas? Just getting back into Windows 10 is all I'm looking for at this point.

Thank you for reading this wall of text, and for any replies in advance.
1 answer Last reply
More about trouble booting windows removing linux
  1. Had to use the Windows 7 install disk to repair it. Go to the command prompt with the repair disk, and typed bootrec.exe/FixMbr. We're up and running!
Ask a new question

Read More

windows 10 Partition Fedora Grub Linux