BOOT_DEVICE_LED on red pc won't start

SPECS:
ASUS Sabertooth X79 LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 ATX Intel Motherboard

MSI NVIDIA GeForce GTX 770 Gaming OC 4GB GDDR5 2DVI/HDMI/DisplayPort PCI-Express Video Card N770 TF 4GD5/OC

Corsair Hydro Series Extreme Performance Liquid CPU Cooler H100i

Intel i7-4930K FCLGA2011 3.40 GHz 64 bit Processor 12MB Cache

CORSAIR vengeance 8GB X 2


I built a new PC which has been running for about 3 months right up until the day i spilled liquid (water) in it. the water went in through the vent at the top of the NZXT full tower case. i immediately turned off the pc disconnected it from the socket and opened it up. i didn't find the water trace anywhere in the pc, i stupidly coupled it back after a space of 30minutes and turned it on, it booted as usual up until the windows startup page where it froze, i then shut it down and restarted but it froze at " THE ULTIMATE FORCE" screen. unresponsive. ever since then it never boots past that.

i stay in West Africa, Accra, Ghana. i had to buy all my parts from the USA online. over here we don't have technicians that can fix high end pc mainly because they don't have readily available replacement parts.

i took this machine to 4 different technicians, 2 of which are big establishment, and all 4 of them blamed it on a dead motherboard. so i went on amazon and bought the same type of motherboard, i finished installation of the new motherboard and the first time i turned on the pc, there were several beeps from the board, i checked and DRAM_LED was red, i did a research on the internet and i found out possible issues was ram incompatibility with the board due to outdated bios.. my board serial number ends with 0906. before updating the bios, i took one ram out and the DRAM_LED went off and now the BOOT_DEVICE_LED stayed red, i returned the ram i removed earlier, the DRAM_LED still stay off but the BOOT_DEVICE_LED stays red. so i updated the bios through the dedicated bios USB slot behind the computer, the BOOT_DEVICE_LED is still red and the pc still doesn't boot past the " THE ULTIMATE FORCE" screen. i can't even access the bios nothing.

so i just wasted money on another board. please what could possibly be wrong with it?
3 answers Last reply
More about boot device led red start
  1. It sounds like to me you had a short somewhere on the previous mobo and the short caused a huge voltage surge and destroyed a few other components with it. You can try removing the gpu and boot g with on board graphocs, or remove 1 ram at a time until you find the cause. Also it very likely might be your psu, a short can backfire into the psu frying crucial components inside, everything may look and function fine but if it's not putting out the exact voltages then it will cause what you are describing.
  2. the MOBO doesn't have on board graphics. i havealso tried botting with 1 ram at a time and no difference. ok if it the psu like you said bearing in mind that i cannot get an extra psu to test with because of my location, what can i tell the next technician i visit to look out for in the psu.
  3. Ask for a PSU thats reliable and highly rated, You want a continuous current PSU, one that's semi modular, or modular. You want it to have at least 35amp + on the 12V line. I would even recommend one like my personal favorites, the Antec High Current Gamer, they come from wattages of 500-620-750-800-1000-1200 and more, I would say the most you need is the 750W only for 100, and will do you magically.
Ask a new question

Read More

Motherboards