Solved

4K U28D590D, Nvidia980, Displayport Powersave Shrinking Windows

I'm having a problem with my new Samsung 4k monitor (U28D590D) that is annoying beyond belief. Setup was easy via displayport to my Nvidia 980 and its running at 3840x2160 60Htz no problem. Any time my monitor goes into standby or is turned off all my windows shrink/resize all of my open windows and moves them to the upper left (Something like 800x600 or 1024x768).

Trying to do research and I seem to find threads from 2012 discussing this issue without any real solutions. Mostly it seems that Microsoft thinks this is a feature and not a bug and applies to most/all displayport setups. Doesn't sound like upgrading to Windows 8.1 helps on this front either from what little I can find.

So far I've discovered:
  • A few apps that don't really work to try and remember windows sizes and restore them
  • tweaking registry settings for a SIMULATED monitor that don't do anything
  • people trying to remove pins from their cables
  • external adapters that emulate a monitor


Is there something I'm missing or is 4k on Windows just a horrible experience of shrinking windows or no power-saving options?

GPU: Gigabyte Nvidia GTX 980
OS: Windows 7
Monitor: Samsung U28D580D
20 answers Last reply Best Answer
More about u28d590d nvidia980 displayport powersave shrinking windows
  1. Are you saying all of your icons/apps just re-sizes and moves to some random spot every time when you bring it back from standby mode? Or am I misunderstanding something?
  2. -Lone- said:
    Are you saying all of your icons/apps just re-sizes and moves to some random spot every time when you bring it back from standby mode? Or am I misunderstanding something?


    Not random. They all move to the upper left and resize to fit into a 800x600/1024x768 box.
  3. element7791 said:
    -Lone- said:
    Are you saying all of your icons/apps just re-sizes and moves to some random spot every time when you bring it back from standby mode? Or am I misunderstanding something?


    Not random. They all move to the upper left and resize to fit into a 800x600/1024x768 box.


    Well, that's pretty weird, never happened to me. When I come out of the standby mode, my icons/apps just stack together in 3 rows horizontally except for there's one empty small row between each of them. I just go to view and auto arrange icons to fix it. So to prevent that, I set my power saving options to never turn off display and never sleep. But I've never heard of the problem you're having.
  4. Are you stuck in that box right now or are you in the monitor's native resolution?
  5. It comes back to the native resolution after re-sizing everything down during sleep. It seems to be a problem with windows falling back to a low resolution because it thinks my monitor is unplugged when it goes to sleep.
  6. element7791 said:
    It comes back to the native resolution after re-sizing everything down during sleep. It seems to be a problem with windows falling back to a low resolution because it thinks my monitor is unplugged when it goes to sleep.


    Somehow yours is different, mine is as I have explained above, so I keep my display and computer turned on until I turn them off myself. But I only turn the TV/monitor off myself, I set my computer to sleep instead of shutdown so that kind of problem doesn't happen. That's the only way I did to fix that, I got so tired of putting where I want my icons, I don't even care anymore and just let them auto arrange.
  7. element7791 said:
    -Lone- said:
    Are you saying all of your icons/apps just re-sizes and moves to some random spot every time when you bring it back from standby mode? Or am I misunderstanding something?


    Not random. They all move to the upper left and resize to fit into a 800x600/1024x768 box.


    "Exact" same problem here - Samsung U28D590D, NVidia Quadro K600, WIndows 7. I also noticed when the monitor goes into or comes out of power save mode, I get the "notification tone" as if I had unplugged/plugged in a USB device. Perhaps the driver gets unloaded and upon reload isn't sure of the screen resolution initially, so it defaults to 800x600 1024 resolutions and places the windows in the upper left?
  8. I was on the verge of returning the monitor because this should just work better and easier but I got it to a point I can live with. The root of the problem is something to do with how Windows implemented Display Port, HDCP and the potential of plugging in an outdated monitor. The seem to have prioritized the use case of unplugging your 4k monitor and hot swapping to a 600x800 CRT over having a 4k monitor go to sleep. The Samsung driver seems to try and correct this but at the same time the Nvidia Driver/Geforce Experience seems to get in the way. Neither Nvidia or Microsoft seem to to believe this is a bug from support posts I've been able to find but then again they are all old.

    My Steps:

    1. This didn't seem to solve it on its own but I did something similar to this post: http://www.tomshardware.com/forum/15424-63-screen-resolution-reboot-windows Basically hard code the native rez of the simulated and Nvidia monitors to 4k

    2. Then I uninstalled completely and cleaned Nvidia drivers and and Uninstalled the Samsung Monitor Driver. Re-installed and Nvidia and then Samsung divers. At this point it would work sometimes and not others. Just a re-install here didn't help, tried that a bunch of times.

    3. I played with the power settings in the control panel. I believe to make my computer sleep and then have the monitor naturally go into power save because the computer did. Honestly there seems to be multiple combinations that work.

    Now this isn't 100% perfect but it works for a computer I mostly use for games. I figure that as more people move to display port and 4k it will improve. Maybe Windows 10 will be better....
  9. Best answer
    Sounds like a basic driver error. Just clean install all of them with Display Driver Uninstaller (DDU) before trying anything more difficult. If that doesn't work, say so here and we'll try something else.

    ________________________________________________________________________
    [HOW TO USE DDU TO CLEAR DRIVERS FOR FRESH INSTALL]

    After changing something in your graphics configuration, graphics drivers can get corrupt or have conflicts that mess things up unless you clean everything out using Display Driver Uninstaller (DDU). Here is the download link to the latest version of DDU:

    http://www.guru3d.com/files-get/display-driver-uninstaller-download,14.html

    It will start downloading automatically. Run it. Let it take you to Safe Mode by restarting the computer. When prompted, check the box to remove the C:\nvidia and C:\AMD folders. Use the option to clean and restart. That will put you back in Windows without any graphics drivers in addition to what Windows will use to display basic stuff.

    Then download GeForce Experience from this link:

    http://www.geforce.com/geforce-experience/download

    Install it, open it, and install the drivers through the program. If the windows doesn't fit on your screen because the resolution is messed up, click anywhere inside the Catalyst window to make sure it the active window, and then press on your keyboard "Window+Up Arrow." That will maximize the window and force it to fit on your screen so you can click on things.

    After the new driver installs, restart - even if it doesn't require you to restart. You'll then be in Windows with new - and only new - graphics drivers.
  10. Eggz said:
    Sounds like a basic driver error. Just clean install all of them with Display Driver Uninstaller (DDU) before trying anything more difficult. If that doesn't work, say so here and we'll try something else.


    In what universe does that sound like a "simple driver error"? When the monitor goes to sleep or is unplugged Windows switches to a lower "native" resolution and resizes the contents of the screen. In a multiple monitor configuration this behavior makes sense since you can't very well resize or drag windows from a screen that you can't see. However, based on your "answer", you obviously don't have a 4k monitor and so have no business giving advice that anyone affected by this problem (like a techie person with 4k capabilities) would have already thought about.

    That said, I dealt with this crappy behavior when I had Windows 7 and 8 on a 1400p DP monitor. I had these same issues on a different computer (HDMI) with my Samsung 4k TV and with my LG 4k TV. In all instances I started from a vanilla OS installation and used the latest drivers and all patches. And this problem never went away.

    I'm not trying to bite your head off, but this is a known problem and your piss-poor attempt at troubleshooting isn't helping.
  11. starmonche said:
    I'm not trying to bite your head off, but [proceeds to bite off head].


    Take a deep breath. Experienced people try the simple stuff first to be efficient. That's why the response mentioned possible drivers issues as a first (easy) step.

    Eggz said:
    [Try DDU for a fresh install.] If that doesn't work, say so here and we'll try something else.


    He never replied saying it didn't work, so it went no further. DDU solves a lot of issues, and even if drivers weren't the main cause, it could have been a confounding factor that DDU would have eliminated for a simpler troubleshooting process. . . . Okay, now breath out and relax ;)
  12. UPDATE: For anyone who had this issue (small windows in upper left corner when waking up from sleep), but DDU didn't solve the problem, I recently came across the same thing and found a fix. It involves making a few simple registry edits. Before doing anything I spell out here, be sure to backup your registry using the simple steps on this link. Just in case anything funny happens (which it shouldn't), you will be able to revert back the registry as though no changes were made if you follow the simple instructions at that same link for restoring the registry from a backup. Also, for general background (totally optional) on editing the registry, read this.

    Don't be scared: I know this looks complication because the post is long, but it really isn't. There's just a lot of words because I want to explain carefully and prevent confusion as much as possible.

    Okay, after you have have a backup, open the registry editor (type "regedit" in start menu and open it . . . blue icon of floating cubes). Then navigate to the source of the resolution issue, which is at at the following location:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    Look under the "Configuration" key (I know they look like folders, but they are called "keys" in the registry context). You'll see a list of keys, and each corresponds to some display configuration that Windows will use in various contexts. For instance, I have a Dell monitor and an Nvidia GPU, so some of the keys under "Configuration" start with "DEL" or "NV," but there are other generic keys that start with something random like "NOEID." Whatever you have there, they all have the same keys listed underneath, and those are what you need to edit.

    Expand each Configuration key one level to expose the key called "00" (some may also have more than one number, so "00" and "01"). Just click on the number key, but don't' expand it. For instance, here is the key location for the number under my Dell display's key, where the bolded part shows the display's whacky--long registry name:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\DELA0A768MCF4CN0ARL_34_07DE_11^9D4D7E896DC19AE06E5F31DD70B7C087\00

    If you click on the "00" (or "01" if you have one), there will pop up a list on the right of files with either a blue or red icon listed under the "name" column. Those are the registry entries for the display configuration. If you have this problem, then three of the entries under the "00" or "01" for your display configurations will have the wrong resolution information. You'll have to enter it manually.

    To find the correct information to enter, focus on these three entries under "00" or "01" for your display: (1) PrimSurfSize.cx, (2) PrimSurfSize.cy, and (3) Stride. The first two define your resolution for whatever display configuration you're looking at. To find which display is your monitor, click through the "00" or "01" key under each display until you find your resolution in parenthesis under the "Data" column corresponding to the entries PrimSurfSize.cx and PrimSurfSize.cy. For instance, my display was under one of the keys beginning with "DEL." My resolution is 3440 x 1440, and I found that PrimSurfSize.cx says "(3440)" and PrimSurfSize.cy says "(1440)" under the Data column for one of the display configurations. This is imporant to note because you can't just type in "3440" or "1440," or whatever resultion you have. You need to type in the code displayed next to the resolution value. For instance, the full entry under "Data" for PrimSurfSize.cx is "0x00000 d70 (3440)." That tells me the code for my X resolution value of 3440 is actually "d70." Similarly, the full entry under "Data" for PrimSurfSize.cy is "0x00000510 (1440)." That tells me the code for my Y resolution value of 1440 is actually "5a0." Finally, the full entry under "Data" for Stride is "0x00003600 (13824)." That tells me the code for my stride value is "3600." Get it? The zeros are just place holders. So take note in this fashion of all entries under the "00" or "01" key for your display (i.e. write if down somewhere, or take and print a screen shot - whatever. Just have it.).

    Now click through the "00" (and if applicable "01" or higher) keys under each display configuration. Do any of the values change compared to the values set in your display, which is the one whose values you just noted? If not, then that's fine. The display values are correct. Move on. Keep going until you find entries that differ from the ones you noted. When you find a difference, double click the entry (i.e. the red or blue icon under the "Name" column). Enter the code you noted for that entry. On my display, the PrimSurfSize.cx and PrimSurfSize.cy were set to a resolution of 640 x 480, so I entered in the codes for 3440 x. 1440; that is, I entered "d70" and "5a0" in to PrimSurfSize.cx and PrimSurfSize.cy, respectively. Make sure all of the entries match the ones you noted. Then exit RegEdit, and restart your computer.

    This will force Windows into always thinking is a space defined by your actual resolution, even when it goes to sleep. To test it, open some windows and scatter them around the screen. Be sure to spread them around. Then put your computer to sleep by either clicking "Sleep" from the start menu or pressing your power button, and then wake it back up. Your windows will now be in the same exact configuration, and they will not bunch up in the upper-right of the screen. That happened because Windows would switch to a sleep resolution, but the registry edit you just did redefined the sleep resolution as your actual resolution. Problem solved!

    Note that I've only tried this on a single display. I don't know what happens on multiple displays, but it's worth a shot. As long as you backed up the registry before making any changes, you'll be able to undo anything you change.

    Hopefully this helps some people, because it was a pain in the A$$ for me to find! Good luck! :)
  13. So I read your solution and tried something a little different but maybe easier to deal with.
    1.) backed up the entire registry under the 'configuration' key
    2.) Delete every key under 'configuration' (I had like 12).
    3.) Rebooted the computer.
    4.) Notice that the system recreated one key for me (the real one in use by monitor i suspect). Check its has the right numbers (in my case 3440x1440 as well)

    I did multiple sleep/monitor off to validate this and it seems to be doing the right thing for now. Long term we shall see but we maybe on to something here!

    Thanks!


    Eggz said:
    UPDATE: For anyone who had this issue (small windows in upper left corner when waking up from sleep), but DDU didn't solve the problem, I recently came across the same thing and found a fix. It involves making a few simple registry edits. Before doing anything I spell out here, be sure to backup your registry using the simple steps on this link. Just in case anything funny happens (which it shouldn't), you will be able to revert back the registry as though no changes were made if you follow the simple instructions at that same link for restoring the registry from a backup. Also, for general background (totally optional) on editing the registry, read this.

    Don't be scared: I know this looks complication because the post is long, but it really isn't. There's just a lot of words because I want to explain carefully and prevent confusion as much as possible.

    Okay, after you have have a backup, open the registry editor (type "regedit" in start menu and open it . . . blue icon of floating cubes). Then navigate to the source of the resolution issue, which is at at the following location:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    Look under the "Configuration" key (I know they look like folders, but they are called "keys" in the registry context). You'll see a list of keys, and each corresponds to some display configuration that Windows will use in various contexts. For instance, I have a Dell monitor and an Nvidia GPU, so some of the keys under "Configuration" start with "DEL" or "NV," but there are other generic keys that start with something random like "NOEID." Whatever you have there, they all have the same keys listed underneath, and those are what you need to edit.

    Expand each Configuration key one level to expose the key called "00" (some may also have more than one number, so "00" and "01"). Just click on the number key, but don't' expand it. For instance, here is the key location for the number under my Dell display's key, where the bolded part shows the display's whacky--long registry name:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\DELA0A768MCF4CN0ARL_34_07DE_11^9D4D7E896DC19AE06E5F31DD70B7C087\00

    If you click on the "00" (or "01" if you have one), there will pop up a list on the right of files with either a blue or red icon listed under the "name" column. Those are the registry entries for the display configuration. If you have this problem, then three of the entries under the "00" or "01" for your display configurations will have the wrong resolution information. You'll have to enter it manually.

    To find the correct information to enter, focus on these three entries under "00" or "01" for your display: (1) PrimSurfSize.cx, (2) PrimSurfSize.cy, and (3) Stride. The first two define your resolution for whatever display configuration you're looking at. To find which display is your monitor, click through the "00" or "01" key under each display until you find your resolution in parenthesis under the "Data" column corresponding to the entries PrimSurfSize.cx and PrimSurfSize.cy. For instance, my display was under one of the keys beginning with "DEL." My resolution is 3440 x 1440, and I found that PrimSurfSize.cx says "(3440)" and PrimSurfSize.cy says "(1440)" under the Data column for one of the display configurations. This is imporant to note because you can't just type in "3440" or "1440," or whatever resultion you have. You need to type in the code displayed next to the resolution value. For instance, the full entry under "Data" for PrimSurfSize.cx is "0x00000 d70 (3440)." That tells me the code for my X resolution value of 3440 is actually "d70." Similarly, the full entry under "Data" for PrimSurfSize.cy is "0x00000510 (1440)." That tells me the code for my Y resolution value of 1440 is actually "5a0." Finally, the full entry under "Data" for Stride is "0x00003600 (13824)." That tells me the code for my stride value is "3600." Get it? The zeros are just place holders. So take note in this fashion of all entries under the "00" or "01" key for your display (i.e. write if down somewhere, or take and print a screen shot - whatever. Just have it.).

    Now click through the "00" (and if applicable "01" or higher) keys under each display configuration. Do any of the values change compared to the values set in your display, which is the one whose values you just noted? If not, then that's fine. The display values are correct. Move on. Keep going until you find entries that differ from the ones you noted. When you find a difference, double click the entry (i.e. the red or blue icon under the "Name" column). Enter the code you noted for that entry. On my display, the PrimSurfSize.cx and PrimSurfSize.cy were set to a resolution of 640 x 480, so I entered in the codes for 3440 x. 1440; that is, I entered "d70" and "5a0" in to PrimSurfSize.cx and PrimSurfSize.cy, respectively. Make sure all of the entries match the ones you noted. Then exit RegEdit, and restart your computer.

    This will force Windows into always thinking is a space defined by your actual resolution, even when it goes to sleep. To test it, open some windows and scatter them around the screen. Be sure to spread them around. Then put your computer to sleep by either clicking "Sleep" from the start menu or pressing your power button, and then wake it back up. Your windows will now be in the same exact configuration, and they will not bunch up in the upper-right of the screen. That happened because Windows would switch to a sleep resolution, but the registry edit you just did redefined the sleep resolution as your actual resolution. Problem solved!

    Note that I've only tried this on a single display. I don't know what happens on multiple displays, but it's worth a shot. As long as you backed up the registry before making any changes, you'll be able to undo anything you change.

    Hopefully this helps some people, because it was a pain in the A$$ for me to find! Good luck! :)
  14. Hi guys.

    I am facing the same problem. Appreciate the solutions - tried both of them. both didn't work.

    Any other ideas?


    boschb said:
    So I read your solution and tried something a little different but maybe easier to deal with.
    1.) backed up the entire registry under the 'configuration' key
    2.) Delete every key under 'configuration' (I had like 12).
    3.) Rebooted the computer.
    4.) Notice that the system recreated one key for me (the real one in use by monitor i suspect). Check its has the right numbers (in my case 3440x1440 as well)

    I did multiple sleep/monitor off to validate this and it seems to be doing the right thing for now. Long term we shall see but we maybe on to something here!

    Thanks!


    Eggz said:
    UPDATE: For anyone who had this issue (small windows in upper left corner when waking up from sleep), but DDU didn't solve the problem, I recently came across the same thing and found a fix. It involves making a few simple registry edits. Before doing anything I spell out here, be sure to backup your registry using the simple steps on this link. Just in case anything funny happens (which it shouldn't), you will be able to revert back the registry as though no changes were made if you follow the simple instructions at that same link for restoring the registry from a backup. Also, for general background (totally optional) on editing the registry, read this.

    Don't be scared: I know this looks complication because the post is long, but it really isn't. There's just a lot of words because I want to explain carefully and prevent confusion as much as possible.

    Okay, after you have have a backup, open the registry editor (type "regedit" in start menu and open it . . . blue icon of floating cubes). Then navigate to the source of the resolution issue, which is at at the following location:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration

    Look under the "Configuration" key (I know they look like folders, but they are called "keys" in the registry context). You'll see a list of keys, and each corresponds to some display configuration that Windows will use in various contexts. For instance, I have a Dell monitor and an Nvidia GPU, so some of the keys under "Configuration" start with "DEL" or "NV," but there are other generic keys that start with something random like "NOEID." Whatever you have there, they all have the same keys listed underneath, and those are what you need to edit.

    Expand each Configuration key one level to expose the key called "00" (some may also have more than one number, so "00" and "01"). Just click on the number key, but don't' expand it. For instance, here is the key location for the number under my Dell display's key, where the bolded part shows the display's whacky--long registry name:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration\DELA0A768MCF4CN0ARL_34_07DE_11^9D4D7E896DC19AE06E5F31DD70B7C087\00

    If you click on the "00" (or "01" if you have one), there will pop up a list on the right of files with either a blue or red icon listed under the "name" column. Those are the registry entries for the display configuration. If you have this problem, then three of the entries under the "00" or "01" for your display configurations will have the wrong resolution information. You'll have to enter it manually.

    To find the correct information to enter, focus on these three entries under "00" or "01" for your display: (1) PrimSurfSize.cx, (2) PrimSurfSize.cy, and (3) Stride. The first two define your resolution for whatever display configuration you're looking at. To find which display is your monitor, click through the "00" or "01" key under each display until you find your resolution in parenthesis under the "Data" column corresponding to the entries PrimSurfSize.cx and PrimSurfSize.cy. For instance, my display was under one of the keys beginning with "DEL." My resolution is 3440 x 1440, and I found that PrimSurfSize.cx says "(3440)" and PrimSurfSize.cy says "(1440)" under the Data column for one of the display configurations. This is imporant to note because you can't just type in "3440" or "1440," or whatever resultion you have. You need to type in the code displayed next to the resolution value. For instance, the full entry under "Data" for PrimSurfSize.cx is "0x00000 d70 (3440)." That tells me the code for my X resolution value of 3440 is actually "d70." Similarly, the full entry under "Data" for PrimSurfSize.cy is "0x00000510 (1440)." That tells me the code for my Y resolution value of 1440 is actually "5a0." Finally, the full entry under "Data" for Stride is "0x00003600 (13824)." That tells me the code for my stride value is "3600." Get it? The zeros are just place holders. So take note in this fashion of all entries under the "00" or "01" key for your display (i.e. write if down somewhere, or take and print a screen shot - whatever. Just have it.).

    Now click through the "00" (and if applicable "01" or higher) keys under each display configuration. Do any of the values change compared to the values set in your display, which is the one whose values you just noted? If not, then that's fine. The display values are correct. Move on. Keep going until you find entries that differ from the ones you noted. When you find a difference, double click the entry (i.e. the red or blue icon under the "Name" column). Enter the code you noted for that entry. On my display, the PrimSurfSize.cx and PrimSurfSize.cy were set to a resolution of 640 x 480, so I entered in the codes for 3440 x. 1440; that is, I entered "d70" and "5a0" in to PrimSurfSize.cx and PrimSurfSize.cy, respectively. Make sure all of the entries match the ones you noted. Then exit RegEdit, and restart your computer.

    This will force Windows into always thinking is a space defined by your actual resolution, even when it goes to sleep. To test it, open some windows and scatter them around the screen. Be sure to spread them around. Then put your computer to sleep by either clicking "Sleep" from the start menu or pressing your power button, and then wake it back up. Your windows will now be in the same exact configuration, and they will not bunch up in the upper-right of the screen. That happened because Windows would switch to a sleep resolution, but the registry edit you just did redefined the sleep resolution as your actual resolution. Problem solved!

    Note that I've only tried this on a single display. I don't know what happens on multiple displays, but it's worth a shot. As long as you backed up the registry before making any changes, you'll be able to undo anything you change.

    Hopefully this helps some people, because it was a pain in the A$$ for me to find! Good luck! :)


  15. Shortly after I posted I realized that issue only occurs when the monitor is powered off. This happens if the screen saver kicks in and then goes to black, or if I just turn the display off manually. This is also the best way to test any possible solution.

    Based on this I found this article:
    http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-7-movesresizes-windows-on-monitor-power/1653aafb-848b-464a-8c69-1a68fbd106aa?auth=1

    For reference, I had 3 keys just like example in the Microsoft forum post. I even tried backing up the configuration root key and then deleting all the keys to see if it would auto recreate them correctly. It does recreate one after a reboot, and the other 2 after your first sleep/monitor off. So 3 seems to be very accurate as the minimum.

    I solved it by modifying the last key 'SIMULATED_...' to match the above ones closely as possible. This included both the '00' sub key and the '00/00' subsubkey data. There solution specifies a few values but I did more just to be thorough, probably overkill. There was only one I didn't touch which was 'flags' because it differed between the other two main keys.

    Best of luck!
  16. boschb - tried that too... still didnt work.

    and I have only 2 key (after trying your option of deleting all the keys under configuration and restarting) - even after turning my monitor off and on. First key belongs to the monitor and the other, the gpu.


    We've been taking about the key under configurations. But the same keys (and a few extra, including simulated key) appears one group down under connectivity - can i touch those too?
  17. deonpang said:
    boschb - tried that too... still didnt work.

    and I have only 2 key (after trying your option of deleting all the keys under configuration and restarting) - even after turning my monitor off and on. First key belongs to the monitor and the other, the gpu.


    We've been taking about the key under configurations. But the same keys (and a few extra, including simulated key) appears one group down under connectivity - can i touch those too?


    Yeah, my solution is a little annoyingly detail-oriented, but I am pretty sure it will work. All resolutions the computer knows are under the keys I specified, and manually setting them all to the same resolution should force the computer to stay in the correct resolution under all circumstances.

    If you want, you can try to combine boschb's solution with mine. That would essentially be just deleting the keys and restarting before doing my solution. If you have a ton of keys, that may save time. But entering several keys wasn't a big deal for me, and I had a lot of them. Hope it helps. Good luck!
  18. boschb said:
    So I read your solution and tried something a little different but maybe easier to deal with.
    1.) backed up the entire registry under the 'configuration' key
    2.) Delete every key under 'configuration' (I had like 12).
    3.) Rebooted the computer.
    4.) Notice that the system recreated one key for me (the real one in use by monitor i suspect). Check its has the right numbers (in my case 3440x1440 as well)

    I did multiple sleep/monitor off to validate this and it seems to be doing the right thing for now. Long term we shall see but we maybe on to something here!

    Thanks!



    This worked for me. Dual Dell P2415Q on NVIDIA GeForce GTX 970 both on DisplayPort. Thanks boschb, it was driving me nuts.
  19. jadeonly said:
    boschb said:
    So I read your solution and tried something a little different but maybe easier to deal with.
    1.) backed up the entire registry under the 'configuration' key
    2.) Delete every key under 'configuration' (I had like 12).
    3.) Rebooted the computer.
    4.) Notice that the system recreated one key for me (the real one in use by monitor i suspect). Check its has the right numbers (in my case 3440x1440 as well)

    I did multiple sleep/monitor off to validate this and it seems to be doing the right thing for now. Long term we shall see but we maybe on to something here!

    Thanks!



    This worked for me. Dual Dell P2415Q on NVIDIA GeForce GTX 970 both on DisplayPort. Thanks boschb, it was driving me nuts.


    None of this works for me. 2 Acer monitors via DisplayPort to 2x GTX 970 in SLI and if I let them sleep I get problems no matter what the registry settings.
  20. Hi everyone,

    I'd been suffering the same problem for weeks and tried the registry changes, to no effect. I then happened to stumble across a setting in my Asus PG279Q options menu labelled 'DisplayPort deep sleep'. (Typically, I was looking for something else at the time.) It was ticked, I unticked it. Problem solved!

    Obviously not everyone has the same monitor, but like I said I missed that setting for weeks. Have a rummage to see if your monitor has something similar. There was also an HDMI deep sleep setting, but I left that untouched as I'm not using HDMI.

    Hope that helps someone.

    Elliot
Ask a new question

Read More

Windows Gtx Graphics Monitors Nvidia