Solved

Second monitor not working with Display Port but does work with DVI

I recently built a computer with two monitors that support 1080p @144hz. The Display Port cables I needed to run it at 144hz arrived today, so I tried installing them, and only one monitor received a signal. The Display Port works with my GPU Display Port but doesn't work with my motherboard's Display Port. I tried detecting a display in the control panel, but no display was detected.
Any idea what is causing this?
I own an MSI GTX 970 GPU, an Asus Z97-A motherboard, and two Asus VG248QE monitors.
Thanks in advance for any helpful comments.
10 answers Last reply Best Answer
More about monitor working display port work dvi
  1. Try:

    Right click on the windows background
    Click Screen Resolution
    Configure your settings.

    Another Thing to do:

    Download the driver(s) for the second screen.

    Should be tutorials everywhere on youtube..
    Hope it was helpful!

    Good luck!
  2. Do you have the intel graphics drivers installed for the onboard graphics?
  3. Bezzell said:
    Do you have the intel graphics drivers installed for the onboard graphics?


    I do not have those drivers installed.
  4. Need to do that.
  5. Bezzell said:
    Need to do that.


    Tried installing the drivers, apparently my system does not meet the minimum requirements.
  6. You need to connect both monitors to your graphics card not one to it and one to the motherboard. Since your graphics card only has one displayport you need to get an adapter for the other.

    EDIT -- The monitor you listed can do 144Hz through the display port and DVI port. So connect one monitor with the DP coming out of your GPU and use a dual link DVI cable to connect the dual link DVI port on your graphics card to the DVI input on the second monitor.
  7. a9ch4f said:
    Bezzell said:
    Need to do that.


    Tried installing the drivers, apparently my system does not meet the minimum requirements.


    You also have to enable the iGPU in the bios first, so the drivers recognize it. May as well use if for the second monitor as it's doing nothing else at the moment.
  8. Best answer
    Enter bios. Advanced > System Agent Configuration > Graphics Config > CPU Graphics Multi-Monitor (set to enabled)

    Then install Intel grapics drivers.

    It should auto detect your 970 as the primary display. You can double check it in the Nvidia control panel.

    This is a good setup if you want the primary display to play games and then use the onboard display just for 2d to watch netflix or play music or something while gaming on the primary.
  9. Bezzell said:
    Enter bios. Advanced > System Agent Configuration > Graphics Config > CPU Graphics Multi-Monitor (set to enabled)

    Then install Intel grapics drivers.

    It should auto detect your 970 as the primary display. You can double check it in the Nvidia control panel.

    This is a good setup if you want the primary display to play games and then use the onboard display just for 2d to watch netflix or play music or something while gaming on the primary.



    Thank you so much for your help. I currently have both screens running at 144hz. You just saved me hours of my time.
  10. Great! Have fun.
Ask a new question

Read More

Monitors Graphics GPUs Graphics Cards Port Displays