No signal after installing new GPU (No beeps, windows boots)

Hi guys

My old nvidia Geforce GTX 460 burned out, so I recently replayed it with a Radeon 7770 HD.

The card had been working flawlessly for 2 days, until I this morning experienced no signal on my monitor - I played on the computer before going to bed yesterday.

I can hear windows booting, no beeps or anything, just no signal on my monitor. The monitor works with other computers, my computer does not with other monitors.

I have also tried reseating the GPU and different VGA cables. I am using the DVI output, with a DVI/VGA adapter.

Time and thought is much appreciated!

EDIT: Formatting
4 answers Last reply
More about signal installing gpu beeps windows boots
  1. Do the fans on the 7770 turn on?
  2. Calnin said:
    Do the fans on the 7770 turn on?


    Yes, all fans going, green light on CPU is lit.

    EDIT: GPU*
  3. I had a similar issue when I last upgraded my GPU.

    Try this...
    1) Hook monitor up using VGA connection from your motherboard (use onboard graphics for starters instead of your card).
    2) Uninstall any NVida drivers
    3) Install your Radeon drivers.
    4) Reboot and try your monitor via video card.

    When I last upgraded my GTX 460 to GTX 770 I got a black screen and it was because the drivers I had were out of date and didnt recognize the newer card.

    I suspect your nvidia drivers have no clue whats plugged in there :)


    EDIT: Nevermind :) I didnt read your entire post. I jumped the gun there. Sorry, please ignore my solution.
  4. Preecher said:
    I had a similar issue when I last upgraded my GPU.

    Try this...
    1) Hook monitor up using VGA connection from your motherboard (use onboard graphics for starters instead of your card).
    2) Uninstall any NVida drivers
    3) Install your Radeon drivers.
    4) Reboot and try your monitor via video card.

    When I last upgraded my GTX 460 to GTX 770 I got a black screen and it was because the drivers I had were out of date and didnt recognize the newer card.

    I suspect your nvidia drivers have no clue whats plugged in there :)

    EDIT: Nevermind :) I didnt read your entire post. I jumped the gun there. Sorry, please ignore my solution.


    Seems plausible! I have already installed the Radeon drivers, will the nVidia drivers still be there?
Ask a new question

Read More

Windows Computers Monitors Graphics