Closed Solved

PC won't enter sleep mode (S3)

I am not sure what is causing my problem, but my computer will not enter S3 Sleep mode anymore. My computer fully supports S3 sleep state and last week is was working correctly. I recently reinstalled Windows 7 Professional 64-bit and it seemed it was working correctly. As you can see in the screenshot, I use only one device to wake up my computer, which is my keyboard, (I've always used this device in the past).

When I put the computer to sleep, the monitor will go off, and it sounds like my speakers turn off as well, it's almost as if it's using S1 sleep state instead of S3, Lights stay on the power supply, the fans are still spinning. I wake up the pc with the keyboard, monitor comes back on, password login screen comes back. I have done quite a bit of searching on Google to find out my exactly problem, but only found answers to what is causing a pc to wake up automatically. That is not my case, as my computer will not sleep correctly anymore.

I think it has to definitely be software loading after windows is booted. I have tried a test, and as soon as I restart the computer and login, I put the computer to sleep immediately and it does it correctly. After a few minutes or hours, the computer won't sleep like it will from a fresh reboot. Something is loading after windows boots and is causing the computer not to sleep correctly. I have also disabled my onboard lan adapter to see if wake on lan is causing the issue. I have went into the bios and disabled WOL and saw S1 and S3 sleep modes supported.

Would somebody please look into this for me, I can give all the information that is needed if required to solve my problem. Thank You

http://img208.imageshack.us/img208/8093/sleepbx.png

Computer
MSI P67A-GD65
Intel I7 2600K @ 4.5Ghz
Patrol 2x4GB 1600Mhz
Nvidia Gtx 580
120GB Vertex 3 OS Ssd
240GB Agility 3 Game Ssd
10 answers Last reply Best Answer
More about enter sleep mode
  1. It could be caused by your motherboard chipset drivers. Perhaps updating/reinstalling the chipset drivers can fix this issue.
  2. Best answer

    Hello and welcome to Tom's Hardware Forums.

    Press your Windows key and R at the same time then in the Open box, type msconfig and hit Enter. Click the StartUp tab and look for anything you think might revert your settings changes on a restart and untick it. So long as you don't untick your AV and firewall, everything else could go with no great loss.

    Click Apply and then on Services tab, tick Hide all Microsoft then do the same then click Apply and OK your way out. Restart and set your sleep settings, restart again and see if they remain the way you want them.

  3. Thank you for welcoming me to the forums. I've always visited tomshardware for years looking up problems other people have had, but almost always able to solve my own problems by Google-ing.

    This problem is just very strange... I just did a reinstall of windows so everything is mostly fresh... It just seems weird the computer will enter sleep mode correctly as soon as I log in to windows from a reboot. Then after a few minutes it wont sleep correctly.

    Since I have read both your posts I have done this.
    Reinstalled:
    Intel Management Engine Driver
    Intel SandyBridge Chipset Driver
    Renesas USB3.0 Drivers
    Realtek PCI-E Ethernet Drivers
    Realtek High Definition Audio Driver
    Marvell SATAIII Drivers

    Went into msconfig:
    Disabled everything in startup
    Went into services, clicked hide microsoft services and the only one that I didn't turn off is
    Logitech Solar Keyboard Service. I'm pretty sure if I disable this one, I won't have a keyboard anymore :(
    -------------

    Now I am uninstalling every program that isn't needed in my programs and features
    Razer Mamba Driver
    Sound Driver
    Ethernet Driver
    Keyboard apps
    Microsoft Security Essentials

    I mean everything, this is what I had left after uninstalling everything that I believe "could" be causing the problem

    http://img20.imageshack.us/img20/1236/22355350.png


    ***EDITED***

    It turns out the problem actually isn't Google Chrome. It's still currently uninstalled and I am still having the same issue. Is my only option now to reinstall windows and hope it works correctly?
  4. I want to thank everybody for all of the help. I should of just uninstalled everything from the beginning and tried out each program one by one. I believe my problem can be marked as solved now.

    For those that are interested in the solution, in device manager I have WSD Print Provider in there. I think it's related to my printer and it's only using generic drivers for it when I should be using the HP drivers. Either way, turns out if it's enabled the computer won't sleep correctly as mentioned above. I disable it and the pc sleeps like a baby. I figured it out by accident just disabling certain devices in device manager one by one and attempting to put the pc to sleep. This of course had to be the last device and it fixed it. Thanks again for all the help and support!

  5. Best answer selected by zbone1.
  6. zbone1 said:
    I am not sure what is causing my problem, but my computer will not enter S3 Sleep mode anymore. My computer fully supports S3 sleep state and last week is was working correctly. I recently reinstalled Windows 7 Professional 64-bit and it seemed it was working correctly. As you can see in the screenshot, I use only one device to wake up my computer, which is my keyboard, (I've always used this device in the past).

    When I put the computer to sleep, the monitor will go off, and it sounds like my speakers turn off as well, it's almost as if it's using S1 sleep state instead of S3, Lights stay on the power supply, the fans are still spinning. I wake up the pc with the keyboard, monitor comes back on, password login screen comes back. I have done quite a bit of searching on Google to find out my exactly problem, but only found answers to what is causing a pc to wake up automatically. That is not my case, as my computer will not sleep correctly anymore.

    I think it has to definitely be software loading after windows is booted. I have tried a test, and as soon as I restart the computer and login, I put the computer to sleep immediately and it does it correctly. After a few minutes or hours, the computer won't sleep like it will from a fresh reboot. Something is loading after windows boots and is causing the computer not to sleep correctly. I have also disabled my onboard lan adapter to see if wake on lan is causing the issue. I have went into the bios and disabled WOL and saw S1 and S3 sleep modes supported.

    Would somebody please look into this for me, I can give all the information that is needed if required to solve my problem. Thank You

    http://img208.imageshack.us/img208/8093/sleepbx.png

    Computer
    MSI P67A-GD65
    Intel I7 2600K @ 4.5Ghz
    Patrol 2x4GB 1600Mhz
    Nvidia Gtx 580
    120GB Vertex 3 OS Ssd
    240GB Agility 3 Game Ssd


    Tried everything I could find on Google with no luck. However I installed an update from Microsoft yesterday (9/21/12) KB2709981 and lo and behold everything is fixed! My screensaver runs now and the PC goes into sleep mode. Hope this helps.
  7. zbone1 said:
    I want to thank everybody for all of the help. I should of just uninstalled everything from the beginning and tried out each program one by one. I believe my problem can be marked as solved now.

    For those that are interested in the solution, in device manager I have WSD Print Provider in there. I think it's related to my printer and it's only using generic drivers for it when I should be using the HP drivers. Either way, turns out if it's enabled the computer won't sleep correctly as mentioned above. I disable it and the pc sleeps like a baby. I figured it out by accident just disabling certain devices in device manager one by one and attempting to put the pc to sleep. This of course had to be the last device and it fixed it. Thanks again for all the help and support!

    http://img232.imageshack.us/img232/3651/problemll.png


    You are a life saver! For how long I struggled with a similar problem and never thought it was the WSD Print Provider. I was suspecting the Ethernet Driver, because whenever I disabled it, the problem disappeared, but no updates nor rollbacks of the Etherenet driver fixed it. Since the problem occurred recently, I thought it was the update of the Ethernet Driver. Now I've got to the bottom of it, I can remember I introduced a WSD Printer Device recently.

    Thanks again to zbone1.
  8. zbone1 said:
    I am not sure what is causing my problem, but my computer will not enter S3 Sleep mode anymore. My computer fully supports S3 sleep state and last week is was working correctly. I recently reinstalled Windows 7 Professional 64-bit and it seemed it was working correctly. As you can see in the screenshot, I use only one device to wake up my computer, which is my keyboard, (I've always used this device in the past).

    When I put the computer to sleep, the monitor will go off, and it sounds like my speakers turn off as well, it's almost as if it's using S1 sleep state instead of S3, Lights stay on the power supply, the fans are still spinning. I wake up the pc with the keyboard, monitor comes back on, password login screen comes back. I have done quite a bit of searching on Google to find out my exactly problem, but only found answers to what is causing a pc to wake up automatically. That is not my case, as my computer will not sleep correctly anymore.

    I think it has to definitely be software loading after windows is booted. I have tried a test, and as soon as I restart the computer and login, I put the computer to sleep immediately and it does it correctly. After a few minutes or hours, the computer won't sleep like it will from a fresh reboot. Something is loading after windows boots and is causing the computer not to sleep correctly. I have also disabled my onboard lan adapter to see if wake on lan is causing the issue. I have went into the bios and disabled WOL and saw S1 and S3 sleep modes supported.

    Would somebody please look into this for me, I can give all the information that is needed if required to solve my problem. Thank You

    http://img208.imageshack.us/img208/8093/sleepbx.png

    Computer
    MSI P67A-GD65
    Intel I7 2600K @ 4.5Ghz
    Patrol 2x4GB 1600Mhz
    Nvidia Gtx 580
    120GB Vertex 3 OS Ssd
    240GB Agility 3 Game Ssd


    I had the same issue, turns out there is a hotfix that seems to do the job!

    http://support.microsoft.com/kb/977307

    Cheers
  9. Bit of an update. After about a week the Microsoft Hotfix stopped working and all the usual shutdown, sleep, boot issues returned. After a lot of messing around I tried removing my graphics card (Asus GTX660 Ti) With the card removed the problems went away, put the card back in the problems returned. Soooooo to cut a long story short, I put the Graphics Card Back in and set my Windows sound scheme to 'NO SOUNDS', the pc now shuts down, sleeps, awakens no problems. My theory is the PC shuts down and or goes into sleep mode before the Graphics card gets a chance to 'power off' leaving it in a Limbo state. It's been over a week now and the PC is still fine.
  10. A novel solution and I hope it remains a solution. Time for this old thread to go to bed now, I think.
Ask a new question

Read More

Configuration Sleep Mode Computers Windows 7