quxszqbaawazabtxtsvyu
Sign-in / Sign-up
Your question
Solved

Help - Can't connect to DNS or ping but get IP from DHCP

Tags:
  • Routers
  • Connection
  • DNS
  • IP
  • Networking
Last response: in Networking
28 August 2012 19:39:19

Hi,
My parents Windows 7 PC has suddenly stopped being able to connect to the Internet. Using the "Diagnose problem" feature in the Manage Network Interfaces panel results in a message claiming that it cannot reach the DNS server and that the connection needs to be reset. Doing so has no effect. It is connected to a DSL router via an ethernet cable.

The NIC is set to dynamically receive its IP and DNS settings via DHCP which it obtains from the DSL router. Executing ipconfig from a DOS prompt shows that this is occurring as expected, with an assigned IP of 192.168.2.10. The gateway and dns are set to the IP address of the router, which is 192.168.2.1. Note that I can't even ping the router at 192.168.2.1.

I also tried static settings in the available range and tried using open DNS IP addresses.

They also have a laptop which connects to the same router wirelessly using DHCP and it is working fine. Using this laptop, I can log into the router and see both it and the problem PC in the list of connected devices, each with the dynamically assigned IP addresses as seen using ipconfig on each. Unplugging the ethernet cable shows the connection status changing in the list of connected devices in the router. From the laptop, I can ping the router and running ipconfig shows that it obtains the same gateway and dns as the PC and the next available IP - 1292.168.2.11.

So this leads me to believe the following:

1- The router, NIC and cat 5 ethernet cable are working fine at the hardware level.
2- The DNS settings in the router are fine, as the laptop works

Perhaps coincidentally, the same day it stopped working they received one of those bogus "This is Microsoft calling" calls claiming their PC was infected, but they had heard of the scam and hung up. Naturally, I started suspecting a virus, but a full system scan using McAffee produced nothing. If it was a DNS changing virus, would I not still be able to ping the router using the IP address?

Any help appreciated.

VM

More about : connect dns ping dhcp

28 August 2012 20:09:40

I would suspect a firewall.

You are correct it is unlikely it is the router or the DNS. When you cannot ping the router you are at the MAC level.

Since you can receive a IP from DHCP your machine can send and receive broadcast packets. The next thing to check is the ARP table to be sure you have a IP to MAC mapping correct. ARP -a from the cmd prompt show show the mac address of the router mapped to the IP. You could also try to ping your laptop and see if it you get that mapping.

The key here is that if ARP works it is as good as ping. Your machine send out "who has 192.168.2.1" and the router responded. So you actually had a 2 way communication. Since when you ping on your subnet you are actually sending a message directly to mac address it should work. Pretty much if arp works but ping does not then it is a firewall blocking it.

If ARP is not working then you have a serious issue with the stack. Removing/updating the drivers will sometimes clear this.
m
0
l
29 August 2012 01:50:44

Try flushing all your network buffers (using Win7, you'll probably have to use an elevated/Administrative command prompt).

arp -d *
nbtstat -R
ipconfig /flushdns

... then reboot.
m
0
l
Related resources
29 August 2012 18:40:53

Thanks, I will give these a try this weekend when I get back up to their place.
m
0
l
2 September 2012 01:50:16

Unfortunately none of these suggestions worked.

I then dragged the PC to my house and attached it to my router with a 10.0.0.1 network. Same deal.

McAfee and Windows firewalls are off.

I am really stumped here. They want to bring it to Geek Squad, but I would really like to save them the $.

Any other tips appreciated.
m
0
l

Best solution

2 September 2012 08:07:32

Try system restore, esp. if this was working until recently.

Btw, I just had someone on another thread w/ a similar problem where everything seemed normal but ended up have to UNINSTALL McAfee.

http://www.tomshardware.com/forum/42247-43-connected-wi...
Share
2 September 2012 20:09:31

Best answer selected by von_d_mills.
m
0
l
2 September 2012 20:27:51

Thank you so much eibgrad!

Once I uninstalled McAfee and rebooted everything was fine. I then checked their email and there were two messages from McAfee stating "A recent update may have prevented you from connecting to the Internet..." - and how were they to see these? Someone will be looking for a new job.

In any event, here is the list:

- Uninstall McAfee: Done
- Log into McAfee myAccount and disable any and all forms of Auto-renewal: Done
- Complete survey asking why you are disabling auto-renewal and tell them their software is crap: Done
- Install Microsoft Security Essentials: Done
- Return PC and get back home to enjoy the rest of the long weekend: Working on it...

I look forward to the day when manufacturers stop bundling garbage like McAfee and Norton with their systems.

Thanks again.
m
0
l
21 December 2012 22:36:12

I am having this same issue with 2 laptops.
McAfee is not installed on EITHER.
BOTH work fine when I plug them directly into the switch I have downstairs (next to Modem).
BOTH do not work on the upstairs switch.
However my DESKTOP PC works just fine on the upstairs switch.

I have turend off firewall on both laptops, flushed DNS, refreshed arp. I have also compairred ipconfig settings between laptop and desktop and everything is in order.

I have even tried assigning static IP just to nake DHCP out of the picture and that did not work.

I am really at a loss for what is going on and why I cannot ping the gateway.

Any ideas other than the ones in this thread?

Thanks!
m
0
l
6 May 2013 01:12:32

I had the same problem, and did all of the stuff suggested here and on other sites I visited. I'm not sure exactly what fixed the issue, but here is a summary of what I did:

First, this was a home wireless network with the router (Cicso WRT110) hooked up to a Cox cable modem. Thank God I had a working computer that could talk to the router and get into the Admin functions. Everything on the network worked great, except one of my Windows 7 laptops. I had three other wireless computers that worked just fine. My laptop could recognize the network, but couldn't get to the internet. When I tried to ping the router (192.168.1.1) from the laptop most of the time it would just timeout, but the occasional packet would go through.

1) I completely cleaned up the laptop. Virus check(s), deactivate the firewall, uninstall unnecessary software, review all services, etc.
2) I restored to the last known restore point where my system did work
3) I cleared the ARP/DNS as suggested earlier in this thread
4) I went into device manager and uninstalled all Network Adapters. Upon reboot, Windows 7 automatically installed the drivers. I had read where malware may have corrupted my NIC drivers. I tried turning on/off IPv6, and checked all of the standard settings for the network adapters.
5) I fiddled with all of the Router settings, to no avail. DMZ/SOS/MTU/Channel - you name it. I ended up just setting everything back to the defaults.
6) Of course, I did the standard turn everything off and reboot - several times.

At this point, I didn't know what else to try. I was at my wit's end. However, I did notice that when I did an ipconfig/all that my laptop always reported that it had the first IP address in the DHCP range and had the word (Preferred) after it. It also reported funny stuff in the Connection-specific DNS Suffix.

So, on a lark, I decided to change the DHCP address range in the router. The old range started at 100. I set the new range to start at 115. All of the devices in my network obtained new IP addresses, as did my laptop. But, I still couldn't connect to the internet, or ping the router without massive delay and pack loss. I really thought this would have solved the problem and was very dejected when it didn't.

Then, as a last final step, I decided to turn everything off, unplug the router, reset the cable modem, and reboot. I did the reboot in this order: Cable modem, then router, then turn on/connect all previously working computers. Only then, turn on and try and connect the laptop.

It worked! The laptop connected, and everything is blazingly fast. I'm sorry I can't tell you exactly what step cured the problem, but I suspect it was reassigning the DHCP address range.

Hope this helps.
m
0
l
2 August 2013 07:02:42

Can try this tool, www.super-ping.com very useful, I always use this.
m
0
l
18 January 2015 23:22:07

Hi Everyone,

This is unusual, but it has happened to me on one occasion - after updating through Windows Update over multiple Internet Explorer versions, e.g.: started with IE8 > IE10 > IE11, without browsing the web between the updated versions then lost internet connectivity. As soon as I started IE11 I was then able to browser the internet and the exclamation mark over my network connection icons disappeared.

I was performing a fresh install of Windows 7 and all updates when this occurred for me.

Kind Regards,

Davo
m
0
l
9 May 2015 03:59:26

Mr Davo said:
Hi Everyone,

This is unusual, but it has happened to me on one occasion - after updating through Windows Update over multiple Internet Explorer versions, e.g.: started with IE8 > IE10 > IE11, without browsing the web between the updated versions then lost internet connectivity. As soon as I started IE11 I was then able to browser the internet and the exclamation mark over my network connection icons disappeared.

I was performing a fresh install of Windows 7 and all updates when this occurred for me.

Kind Regards,

Davo


Oh man this is exactly my situation here. I will try on this, cheers.

m
0
l
1 June 2015 08:38:51

I had a similar situation and tried all the suggestions but it did not work.

Finally made the following change in Device Manager and immediately the PC got connected:
Double clicked to show properties of the network adapter/card:
Under the Advance Tab:
Changed property of 802.11n bandwidth 20MHz only to 20/40Mhz
After making this changes the PC manage to connected to the router immediately
m
0
l
6 July 2015 05:30:48

Update: Computer now fixed, failure was caused by a banal problem on the inside of the computer. It turned out to be a disconnected wifi antenna cable inside the laptop. Had to take the laptop apart, pop the cable back in, and everything works smoothly.
Best of luck to all other troubleshooters.

_____________________________________________________________________________
Hello everyone. I'm having a very similar problem with my brother's Windows 7 computer. When connected to the wifi, windows shows a little yellow exclamation mark next to the wireless network tray icon and says there is no internet connection in the network. Other computers/phones connected to the same wifi have internet connectivity and everything works. An error with the router/access point can therefore be ruled out.

When connected to the wifi, the computer can't ping any other device on the network, not even the router/default gateway. The computer itself is also not pingable from other devices. When connected to the wired network, internet access and pings in both directions work just fine.

The network is set up to give clients DHCP addresses and the computer is able to obtain an IP address on both wired and wireless connections. Using the arp -a command, I can confirm it's even able to resolve the default gateway mac address when connected to the wifi network. This leads me to think that on the HW level the network stack on the computer is fine.

The funny thing is, that this behavior is only present on the home wireless network. When connected to any other wifi network, the connection works just fine. Also, when connecting to a different AP on the home network (with a different SSID) the wifi also works fine.

I've tried the following steps to resolve the situation, but to no avail:
- restarting the computer (duh)
- setting IP addresses to manually configured for the wifi connection
- manually setting public DNS servers to my default gateway, and a few of these: 208.67.222.222, 208.67.220.220, 4.2.2.2, etc.
- flushing the dns cache with arp -d *, nbtstat -R, ipconfig /flushdns followed by a reboot
- turning windows firewall completely off
- updating wifi drivers to the latest version
- changing the SSID of the home wifi network
- changing property of 802.11n bandwidth to 20/40 Mhz
- virus check and uninstallation of unnecessary software
- turning IPv6 off in the wifi network properties
- rebooting the router and the Access point several times
- starting the computer in safe mode with networking

The behavior remains the same as described above, so I'm really at a loss about what else to try. System restore is turned off due to limited SSD storage, so that's not an option. The only other remedy I can think of is a clean windows reinstall, which I really would like to avoid.
Any ideas on what could be the problem?

Thanks.
m
0
l