Solved

My External Hard Drive cannot be Accessed

Hello there,

For almost three months, I've been happily using my Buffalo HD-PNTU3 External Hard Drive. It's been working fine, save for the same problem I'm experiencing now when I first used it. I had fixed this problem my connecting the Ex. HDD to a regular USB port, rather than using an expansion USB hub.

So, here's the problem:

I cannot access my external hard drive whatsoever. I had been able to use it for a while, until I decided to switch ports. I safely removed the hardware and proceeded to change ports.

And then, this happened: http://scr.hu/227/ul5rk and http://scr.hu/227/ty8i4

I cannot access my (E:) drive— it was previously accessible as my External Hard Drive, but now it is being temperamental with me. I had checked the Device Manager to see if it was still recognized, and it was.

Shown here: http://scr.hu/227/g3fdo

I also checked the Disk Management:

http://scr.hu/227/elp5g

Both instances show that it clearly exists and I'm not some mad fool. I have tried reconnecting it to its original port, but alas, no results were shown, only more failure. Updating the drivers didn't seem to help, and nor did uninstalling/reinstalling them help either.

If you can be of any help, please recommend some tips!

----

I am running Windows 8, if that's a factor. I've also tried using it on a Windows 7 computer, but the same problem persisted.
2 answers Last reply Best Answer
More about external hard drive accessed
  1. Best answer
    QUOTED SPAM REDACTED - SS
    Well, before I saw this, I actually tried running a dskchk, and it cleared everything up. Thanks anyways! ^^
  2. Best answer selected by SimonBane.
Ask a new question

Read More

Hard Drives External Hard Drive Storage