No media flash drive

my usb drive doesnt work..

right now im on windows 7, it came broke from a vista computer, and i've tested it on an XP sp3 computer.

windows see its, recognizes it.. gives it a label and calls it media, but it has 0mb of capacity.
clicking on it yields "please insert disk into D:".

I have changed the volume letter, and tried to change the volume name..
i have tried to use various recovery tools, all of which detect no media.
I have attempted to format the drive with multiple tools, all of which discover no media.
of course all windows disk management tool are of no use.

---
disk : disk 1
Type : Removable
Status : no media
partition style : MBR
capacity : 0mb
unallocated : 0mb
Reserved : 0mb
---


This drive has all of her final papers for this semester, its important.

Its a Kingston 8gb flashdrive.
Reply to bhawin
4 answers Last reply
More about media flash drive
  1. Does not seem like there is nothing you can do to fix it. If you can't format it, it's dead.

    You may be able to fix it by installing the actual electronics into a new USB connection.
    Reply to hang-the-9
  2. did you try using it on another computer? I have one that won't work on my xp desktop but works on my win vista and win 7 laptops.
    Reply to Carpathice
  3. The flash is damage,can not recovery any data.
    Reply to haska
  4. I am having the same problem of "No Media" from my Sony Micro Vault flash drive of 4GB, 3.0 USB, bought in 2013, and rarely used.
    Reply to omegaman2
Ask a new question Answer

Read More

Flash Media Storage