2.5'' WD HDD good health, but unable to format. Thought?

Drive model number: WD1200BEVE (2.5'' 120GB, pulled from a laptop)

This is a drive that was tested with many different programs such as HD Tune, ADRC, HDD Regenerator, GParted, WD tools, and others; all those diagnostic programs show no problem at all with the drive. The drive is recognized by the laptop, and when attached externally to a desktop PC. It is possible to create and delete partitions.

The issue is that I cannot format the drive. When the formatting starts, it formats till the end, then it says that the drive could not be formatted. I tried to create 3 different partitions and format each partition. Same issue with all the 3 partitions.

What I don't understand is that the drive doesn't show bad sectors, diagnostic programs says it is in good health, but I am unable to format it.

Does anyone know what kind of problem could this be?
2 answers Last reply
More about good health unable format thought
  1. An interesting problem. What software are you using to format the drive?
  2. I tried to format with Windows 7 and GParted.

    Windows just says that is unable to format the drive.

    Gparted says that I need to run "chkdsk /f" before formatting the drive. The problem is that I cannot run chkdsk unless I format the drive first.
Ask a new question

Read More

Hard Drives Western Digital Format Storage