Computer wont boot or post. Ive tried everything help!!!

So im trying to build this computer and for some reason the PC wont boot/post. I dont hear any beeps at all.

ECS G31T-M Motherboard
Q9300 CPU
4GB PC 6400 800mhz RAM

So i tryed building that last night, all the leds/fans go on but no boot or post. I unplug the DVD Drive, reduce the ram to 1 stick- stll doesnt boot. I replace the Power supply, still doesnt boot.

Today i go return the motherboard for a new one and get a Celeron 430 CPU. I try the new motherboard and still doesnt boot or post. I install the Celeron CPU and still nothing. I just unplugged everything and left it on basics and still no beeps. I switch a stick of RAM from my PC and switched to a known working PSU and it doesnt work. Ive taken the battery out, reset CMOS. Still nothing at all on the monitor. Someone please help me.
4 answers Last reply
More about computer wont boot post help
  1. try a different monitor/cable? start there.
  2. The monitor and cable work fine on 2 other computers. I dont have any extra monitor/cables though. I know this one is working perfect
  3. First of all you only need to have the basics to see if it will post. The magical beep.
    You need motherboard, ram, cpu (heatsink also) and powersupply.

    Without the case lay out on non conductive surface hookit all up and then use a screw driver the jump the start pins on the mother board. If she beeps your up and running.

    Other issues could be ram and cpu compatiblity with mother board BIOS. Go to the manufactues web site to see whats supported and on what BIOS update may or maynot be required. My hunch seems to lead towards ram.

    Oh the other thing i forgot to say is if your motherboard does not have a tiny pizo (speaker on it) you need to connect the speaker from the case to the motherboard to hear the beep some motherboard have them on as an attatchment if the computer case lacks a speaker
  4. Thanks alot for the help so far.

    The mobo didnt come with a speaker, I attached the one that came with it. I checked the website and the Q9300 works on the mobo but only with a bios update so thats why I have a celeron in there At the moment. IT supports the type of ram I have, 2GB 800mhz RAM, i just used a stick from my pc and it didnt help. The problem is that I dont hear any beeps at all and I still cant. Ive tried everything, Im thinking it might be another bad motherboard or a bad CPU. But anyone have any other ideas of what I can try out?
Ask a new question

Read More

Homebuilt Computer Boot Systems