APC BX1000 Click-of-Death Repair

I was generally impressed by the build and component quality that went into APC's 10-year-old APC BX1000. Little did I know I'd be writing a repair story about it two years later.

If there's something you should have learned about me by now, it's that I despise hardware the manufacturer cut corners to make. Also, I hate giving up on what should still be usable hardware. When my BX1000 failed in December 2015, despite what appeared to be great design and execution, I was surprised. I cracked it open and couldn’t find anything visually wrong with it. Quick spot-checks failed to reveal anything obvious. So, I bought the Cyber Power LX1500 and tossed the BX1000 in my “fix it later” pile. After nine months of hunting down lower-end to mid-range alternatives, tearing them down and being repeatedly disappointed by their quality, I decided it'd be a good time to revisit the APC unit for a more serious attempt at UPS necromancy.

What symptoms did my BX1000 present back then? A picture is worth a thousand words, so I’ll let this short video tell the story before I go into more depth:

APC BX1000

The clicking did not start quite so bad. It began around October 2015, coincidentally when the landlord turned the electric boiler back on. The UPS responded with a few clicks each time the boiler and its pump kicked on. I measured line voltage and found it to dip as low as 107V on cold nights, so I initially shrugged it off as the boiler start-up dragging line voltage low enough to make the UPS’ voltage regulation kick in.

It got progressively worse from there until December, when every minor line voltage fluctuation caused the UPS to go into a clicking frenzy, occasionally followed by the UPS switching to battery backup for an increasingly long time, and then going back to line power. Checking AC voltage with my oscilloscope revealed nothing to explain the UPS’ behavior, and probing its output showed that the clicking happened to be the AVR transformer getting switched in and out of boost mode, which was consistent with the line voltage sags I measured previously. By the time I retired the BX1000, it would no longer reliably power up while connected to AC power. When it did, it took forever for the UPS to switch back to line power, even when my instrumentation said the input looked perfectly fine.

What could cause a UPS to fail in this manner? Mainly, I suspected bad power delivery to the circuitry managing input voltage detection, loss of power or bad power at the UPS micro-controller, or a loss of filtering at the detection circuitry’s inputs causing it to trip on input noise. I don't know how line voltage monitoring issues could be related to the UPS failing to start, but perhaps we'll find out.

Since everything appears functional, aside from the erratic behavior, I am optimistic that today's exploration will end with a simple, definitive fix.

MORE: APC BR1000G Tear-Down
MORE: APC BN650M1-CA Tear-Down
MORE: APC BGE90M-CA Tear-Down

Create a new thread in the UK Article comments forum about this subject
This thread is closed for comments
No comments yet
Comment from the forums
    Your comment