Motherboard not working after ram upgrade. System booting in the bios and no usb power

Hello all,
I have an ASRock b450M with AMD Ryzen CPU and a Trident-Z.
I tried to mount a different DIMM but something went wrong. I powered on the motherboard but the cpu fan just run for half second and then nothing happened. I got same results 3 o 4 times. At some point the cpu fan started running but the system entered in the bios. Mouse and keybord did not work and I noticed that there wasn't power from the usb. So I was stuck in the main page of the bios.
Therefore I tried to mount back the old DIMM. However I get same results. The motherbord powers on but I get in the bios main page and the usb ports do not work. The main page tell me that the system properly recognize the hardware. I have cleared the cmos but no results. I cannot understand how it's possible.

Someone have any solutions?
2 answers Last reply
More about motherboard working ram upgrade system booting bios usb power
  1. maybe buy a PS2 keyboard the old type with round connector
  2. RARRAF said:
    maybe buy a PS2 keyboard the old type with round connector


    I tried with a ps2 keyboard it works. However in the bios seems to me that usb is enabled. I have a ssd attached but no sata devices detected.
Ask a new question

Read More

BIOS CPUs Motherboards