Solved

Monitor Loses its signal while installing graphic card driver...Is that a sign of dying gpu?

So Recently I just build a pc using refurbished parts that i bought from a refurbished pc store.

After setting it up and install the os, I've try to install the driver for the graphic card and during the process, my monitor turns black and loses it signal. But If I try to boot to safe mode even with the graphic card plugged in, I manage to go there(safe mode) and saw my graphic card listed in device manager.

I've try many ways including changing my psu to a new one and even using ddu.

Is it a driver problem or hardware problem? Or My gpu is dying?
Cause I'm now out of options to do with it.
Please help.
5 answers Last reply Best Answer
More about monitor loses signal installing graphic card driver sign dying gpu
  1. What is the make/ model of your monitor and GPU?
    When in safe mode what is the display resolution and refresh rate?
    Btw, I think things will be fine.
  2. How long are you leaving the system before messing with the reset/power button? The screen going blank for 5-10 seconds is normal during a gfx driver install; and sometimes for upto 15-20 seconds. It may go blank and then come back several times.

    Also, some cards dont seem to like the current drivers; a Nvidia user reported issues yesterday; going back to an older driver worked; and I have a similar issue with my AMD card; it doesnt like the new generation of AMD drivers and only works properly with a driver from last summer.
  3. Grugbug said:
    What is the make/ model of your monitor and GPU?
    When in safe mode what is the display resolution and refresh rate?
    Btw, I think things will be fine.


    My GPU is Gigabyte GTX 760 2G
    My Monitor is LG FLATRON W2242T

    In Safe Mode the display turn into 1024x768 and the refresh rate 60Hz
  4. CaptainCretin said:
    How long are you leaving the system before messing with the reset/power button? The screen going blank for 5-10 seconds is normal during a gfx driver install; and sometimes for upto 15-20 seconds. It may go blank and then come back several times.

    Also, some cards dont seem to like the current drivers; a Nvidia user reported issues yesterday; going back to an older driver worked; and I have a similar issue with my AMD card; it doesnt like the new generation of AMD drivers and only works properly with a driver from last summer.


    It's goes blank around 5 seconds and shows no signal. Then, no display after that around 30 minutes or so until I pushed the power button. I've tried the drivers even the last year drivers and windows 10 compatibility drivers also gave the same result.
  5. Best answer
    Once you have power cycled, it all works correctly and the new drivers show as installed??

    It might be a power configuration issue; perhaps the updater cannot restart the graphics system for some reason.

    Yes, it might be the card going south, but equally, it might be the installer isnt being tested properly on older cards, and is messing up. Win10 is a bugfest for any non standard install.
Ask a new question

Read More

Safe Mode Graphics Cards Monitors Nvidia