Ryzen 2200g wont post tried everything

Had gtx 1060 with ryzen 5 1400 on asrock b350m pro 4 worked perfectly
Sold gpu and cpu (needed money ) and bought 2200g and suprise suprise it didnt boot ,so i flashed bios , cleared cmos tried every single option , every post here and on reddit , still nothing , fans spining no posting
Any ideas ?
5 answers Last reply
More about ryzen 2200g wont post
  1. If header available, try connecting an internal speaker to the motherboard and see if any beeps with no RAMs,
  2. No speaker fuk .....
    Buut i noticed that pc is restarting without ram , with ram it just powers on and stay
  3. Try booting it with on stick of RAM. Try it in each DIMM and see if it will post. Ryzen is finicky when it comes to RAM.

    I would also assume you have downloaded the latest bios flash? Could you have flashed it with a previous version?
  4. Only have 1 stick of 8gb so i tried every dimm but guess what happend ;), yeah latest version of bios
  5. Im not an expert but sure here are some , arent there any tips or something anyone could suggest?
    It could be dead cpu i guess but ill wait 30 days for store to check and i want that to be my last option
Ask a new question