New components on AM4 mobo, CPU and ram red leds on, no display at all

I just bought a new "trio" to upgrade my PC. The components are:

AMD Ryzen 3 1200 CPU
Gigabyte GA-AB350 Gaming 3
HyperX Fury Red 8GB DDR4 2133MHz CL14 1.2v

The unpleasant surprize, is that after I assembled all components, the system won't start properly. The PSU, the cpu fan and leds on the case are working, but i got absolutely nothing on the monitor (stays in stand-by), not even the bios or the motherboard logo screen, nothing. I work with desktop PC's since 2006-2007, but I never experienced something alike...

My other components are working perfectly, yesterday they ran on my old system (500W psu, Nvidia 1050, 120 GB kingston ssd).
The motherboard has in the bottom right corner, 4 red leds for malfunctioning purposes (cpu,ram,vga and boot). In my case, the CPU led was blinking (long blinks), and ram (short blinks). I ckeched over and over for eventual case-shortcircuit, i reset the cmos, i double checked all the wiring, but the outcome is still the same...

What could those red blinking mean?? Could be some components compatibility issues? As far as I checked before buying them, they were compatible...

Any advices?

Cheers!
8 answers Last reply
More about components am4 mobo cpu ram red leds display
  1. What kind of PSU do you have? That could possibly be the culprit but it could also be the motherboard. I'd check the PSU first.
  2. Thanks for the reply. Already checked with another PSU, the same result remains... At least if I could go into bios...and flash to other versions...but nope.
  3. ionutz_contact said:
    Thanks for the reply. Already checked with another PSU, the same result remains... At least if I could go into bios...and flash to other versions...but nope.


    Flashing won't do much, sounds like your motherboard will most likely need to be RMA'd.
  4. try posting the mb on top of the mb box with the gpu and one ram stick. see if it was shorting out in the case. with the mb check the mb vendor web site for bios rev needed to post. make sure your mb has the right bios to post.
  5. I already tried that, but without success. I tried my memory on another pc and is working. So, I think is a board problem... Unfortunately I can't access the BIOS, the display remains in stand by when I power up the PC, whatever I do...
  6. check the cpu make sure there no bent pins. on the side of the motherboard make sure the eps power plug is connected and you used the right cable. on power supply dont use the 6 plus two cables those are for video power.
  7. Update: Finally after dozens of failed attempts, I managed to make it work.
    After reading in multiple places, i tried to enter into the backup bios somehow in many ways, but the method that worked for me was following: PC was off, then I pushed simultaneously on Power and Reset buttons for 10 seconds, and that was it. It loop-booted the motherboard splashscreen about 2-3 times, and after that, it booted windows 10. It runs smoothly since then. I checked BIOS, is version F7, and, despite the fact that on the mobo site are a few newer versions released, I will stick to F7, since it runs OK. I can't imagine what was the problem...perhaps some problems with main bios, some little glitch, that somehow disappeard after I tried to boot in backup bios.
    Thanks for all your help!
  8. This may seem weird, but in the past, I've found I needed to clear the cmos of a board on a new build before it wanted to boot up properly.
Ask a new question

Read More

Gigabyte Components CPUs