Can’t play any game with new build.

So I a built a new pc with all new parts except the power supply and the gpu I took that off my last build. But I can’t play games they run for 1-2 minutes then start freezing up crashing or I get a black screen and then it will go away I end up having to start my pc after because it becomes unusable. Some times I can close the game and everything will work find after. Tried multiple games. Been trying to figure out what the heel is causing this. Everything works perfect up until time launching games I actually did run the furmark gpu stress test and it’s crashes within 15-30 seconds in.

My specs are
I5 8600k
Asrock z370 killer
EVGA Gtx 670
Corsair tx650
G.SKILL TridentZ Series 8GB (2 x 4GB) 288-Pin DDR4 SDRAM DDR4 3200
WD Black 2TB Performance Desktop Hard Disk Drive
Win10
Reply to ahamburgler664
13 answers Last reply
More about play game build
  1. What temps are you seeing?
    Reply to jay32267
  2. ahamburgler664 said:
    So I a built a new pc with all new parts except the power supply and the gpu I took that off my last build. But I can’t play games they run for 1-2 minutes then start freezing up crashing or I get a black screen and then it will go away I end up having to start my pc after because it becomes unusable. Some times I can close the game and everything will work find after. Tried multiple games. Been trying to figure out what the heel is causing this. Everything works perfect up until time launching games I actually did run the furmark gpu stress test and it’s crashes within 15-30 seconds in.

    My specs are
    I5 8600k
    Asrock z370 killer
    EVGA Gtx 670
    Corsair tx650
    G.SKILL TridentZ Series 8GB (2 x 4GB) 288-Pin DDR4 SDRAM DDR4 3200
    WD Black 2TB Performance Desktop Hard Disk Drive
    Win10


    First of all, I suspect a pretty large bottleneck with your new I5 and a GTX 670. It's possible your GPU is failing, try pulling it out and using onboard graphics if you have them. If not you can always revert to ebay and buy a cheap AMD card for a few dollars on Ebay, I found a Radeon hd 5450 for 10 dollars.
    Reply to jacobweaver800
  3. The temps are normal the cpu is at 29-30c with no load. I’m going to try to use the igpu now. Should I try and fire up a game with it.
    Reply to ahamburgler664
  4. So I tried the igpu and went into the easiest game I got which is 7 days to die and it ran I started went into a game just such low FPS I couldn’t play but it ran fine no freezing no anything. Then I tried the gtx 670 and actually got into the game and played for 30 seconds then I raised the graphic setting to high and it all went down hill and started freezing and black screens so I had to restart my pc. Now it’s freezibg right when I fire up windows so I had to go back to the igpu. So at this point would you guys think It’s safe to say it’s the gpu causing this.
    Reply to ahamburgler664
  5. ahamburgler664 said:
    So I tried the igpu and went into the easiest game I got which is 7 days to die and it ran I started went into a game just such low FPS I couldn’t play but it ran fine no freezing no anything. Then I tried the gtx 670 and actually got into the game and played for 30 seconds then I raised the graphic setting to high and it all went down hill and started freezing and black screens so I had to restart my pc. Now it’s freezibg right when I fire up windows so I had to go back to the igpu. So at this point would you guys think It’s safe to say it’s the gpu causing this.


    Well there are 2 options:
    1. Due to the psu being older it can be that the moment it needs to deliver more power it is failing to do so and causing crashes (that would explain why your igpu gaming is fine).
    2. The gpu is dying.

    Unless you can test the gpu in another system there is no way to be sure that it's the gpu or the psu.
    What was your previous system the tx 650 and gtx 670 were in?
    Reply to jaslion
  6. Yes both my last system had the Gtx 670 and tx650 psu with an i5 2500k and it ran good.
    Reply to ahamburgler664
  7. I’m about to go pick up a 600w psu and test that
    Reply to ahamburgler664
  8. ahamburgler664 said:
    I’m about to go pick up a 600w psu and test that


    Yeah that's probably the issue, although don't rule out the GPU yet as it is still an old card.
    Reply to jacobweaver800
  9. Woah dude, I just ran the bottleneck test on your hardware and it got a 46% bottleneck, above 10% is considered a bottleneck, you really need to get a better GPU. http://thebottlenecker.com/#calculator test it for yourself here.
    Reply to jacobweaver800
  10. That is one cool utility.
    Reply to jay32267
  11. Ok so my buddy had a Eva gtx1060 ftw 2 so I bought that from him then picked up another power supply an EVGA 600 and now everything works perfect thanks for your help guys.
    Reply to ahamburgler664
  12. jay32267 said:
    That is one cool utility.


    Yeah, I'm glad they made it It should get a lot of new builders.
    Reply to jacobweaver800
  13. ahamburgler664 said:
    Ok so my buddy had a Eva gtx1060 ftw 2 so I bought that from him then picked up another power supply an EVGA 600 and now everything works perfect thanks for your help guys.

    Yeah, you shouldn't have any bottlenecks now, as well as a way better experience in games.
    Reply to jacobweaver800
Ask a new question Answer

Read More

Power Supplies Games New Build