No power up after changing memory frequency

So I've been going through a lot of troubleshooting and I'm starting to get stumped/desperate.

Ryzen 5 1600x
Asus ROG strix b350-f motherboard
G.skill ripjaw V 16gb 3000[2x8]
GTX 1060
850 EVO M.2 SSD

I built a brand new computer and it booted into the UEFI first try. So I'm looking around in the menus and see that my memory was set to 2133. I see a drop down menu to change the frequency, so I changed it to 2933 and hit save and reset. Didn't think that was anything major since my RAM is rated at 3000. The computer resets, then powers off and now nothing happens when I press the power button. The power LED on the MB is on, the Aura LEDs are changing colors, but the PSU fan and all the components don't start up when I turn on the PSU and nothing happens when i push the power button on the case or with jumpers.

* I've reset the CMOS by taking out the battery, shorting the jumpers.

* I tried jumping the power from the MB just incase the button wasn't working.

* I tested the PSU by itself with paperclip and a hard drive connected and the PSU and hard drive both worked fine, but once I reconnect the 24 pin to the MB and turn on the PSU the fans or other components don't turn on. only lights. The pins on the MB connector look fine. None bent.

* I tried every possible RAM configuration in every slot.

* No wires or metal parts are touching the back of the MB.

Running out of things to try to make this work. Maybe I'm missing something here. Maybe the board is faulty? Would appreciate any help in this. Thanks
2 answers Last reply
More about power changing memory frequency
  1. Clearing the cmos should have reset that back to normal. Did you try pulling one of the memory sticks, and running with just one?
    It's weird psu fan isn't starting up though, even though psu seems to be ok on its own.
  2. Yea, think i'm going to RMA the board.
Ask a new question

Read More

Overclocking Power Up Memory