Parallel ATA (PATA) optical drive won't boot when SATA mode is set to AHCI

I'm working with an old Gigabyte MA78GM-US2H (rev. 1.0) motherboard... and an equally old Parallel (ATA) ribbon cable optical drive. After changing the Registry to make a previously IDE mode Win7 installation boot in AHCI mode, I seem to have lost the optical drive's ability to boot. (yes, the boot order is correct)

The option to boot from CD-ROM appears on the POST startup screen as normal. But nothing happens when I press any key. After a long time, I am given the option to boot to the OS.

If I change the SATA mode back to IDE, the optical drive can be used to boot again, but of course we don't want IDE mode. I feel the problem has to do with the BIOS change to SATA mode somehow affecting the PATA boot capability. But I'm stumped. And open to suggestions.
1 answer Last reply
More about parallel ata pata optical drive boot sata mode set ahci
  1. I very vaguely remember having a similar issue years ago - essentially, the BIOS was set up so that it'd either look to boot from (P)ATA or SATA, and wouldn't look in both places. It's probably just an oversight (or something deliberately omitted because it'd be hard to accomplish - BIOSes were extended WAY past what anyone thought they'd be used for, and I've got a general feeling most of the things they did by the 21st century were hacks built on a hope and a prayer).

    I know that this isn't the answer that you're looking for, but given that a 16GB flash drive is <$5 (and there's a very good chance you've got some lying around), why not just boot up, copy the CD or DVD as an image to the USB drive, and boot off of that? A drive that can saturate USB 2.0 will be a lot faster than the optical drive, as a nice bonus.
Ask a new question

Read More

Motherboards SATA Boot Optical Media Gigabyte