SSD can't erase

I'm having a macbook pro 15 retina early 2013, in which I'm trying to erase my ssd because high sierra osmy has been corrupted showing folder question mark. I can only access internet recovery. My ssd is detecting in diskutility as UNINITIALIZED. I thought that my ssd has failed, but when I erase it, it's says waiting for disks to reappear at 50%. I tried pdisk command in terminal where I can initialize, write partitions to my ssd but that doesn't show up in diskutil list. I did this because to check whether my ssd is functioning properly or not.

I asked help from several forums they said to mount my ssd externally to a Linux through livecd and use gparted. the same problem occurs cant format using ext4 or fat32 or even hfs+. it detects as a unrecognized label and shows my file system as unallocated.

Im slowly trying to understand the fact that my ssd is failing but my question is how can it detect or how can it initialize and write partitions through pdisk and I checked badblocks and no badblocks occurred in my process. Also when using dd in terminal it stated some records are in and some records are out like that.
I tried zerodisk erase which did till 99%and after that stated error 69759 erasing failed and underlying error 5 input/output error

I guess that the ssd is not failed but the ssd is corruted with no file system

I literally did everything possible I can. Kindly help me
No answers Last reply
More about ssd erase
Ask a new question

Read More

Macbook Pro SSD Filesystem