AMD RAID: 1 Legacy Drive goes "offline" when adding additional drives

I'm completely stumped on this one.

I have an ASUS ROG B350-F It has 6 SATA ports. Although it seems that four are the only ones recognized by the RAID system.

I had it set to AHCI and I went through the process of converting it to RAID. I have one 4TB drive connected to it. I converted it to RAID and could boot just fine. In the RAID configuration program it simply shows it as "Legacy"

If i shut it down and connect my two 500GB drives (that I'd like to have setup in a RAID 0). I immediately go into the RAID configuration and my 4TB drive shows up as "Offline". I don't have any option to turn it online. I believe I have the option to delete its "array" configuration and re-create it but I don't want to lose the data on the drive! (Yes, it's backed up but still.)

What is going on? I don't understand why I suddenly can't access the 4TB drive. I tried moving it to the two ports that don't seem to be visible to the controller and it still doesn't show up in Windows.

Any advice would be helpful.
1 answer Last reply
More about amd raid legacy drive offline adding additional drives
  1. After two days of attempting to talk with ASUS support (with every e-mail I responded, a new ticket would be opened and a new technician would answer.) I finally just tried again and it worked without a problem.

    The only thing I can think of is the SATA cable was getting disconnected from the 4TB drive when I would fiddle in the case. I can't think of anything else.
Ask a new question

Read More

Asus NAS / RAID Legacy AMD Configuration