Asus Z170-A USB 2.0 (9 pin) not working *please help*

I don't know if I'm just an idiot, but I don't think my internal USB 2.0 headers (9 pin) on my motherboard are working, or showing up in Device Manager at all.

How can I test this?

The problem:
I bought Corsair LL120/140 RBG fans and the LEDs do not work. I thought it was the lighting node pro that comes with, they sent me a new one and still it does not work. The fans spin, but no LED.

My PSU is a seasonic 650W gold and GPU is EVGA GTX 1070 FTW. I have heard that EVGA Precision XOC isn't compatible with Corsair's Link program, but even so... I believe the USB should show in my device manager list.

I've updated the BIOS, Chipset, and USB drivers directly from Asus. And reset bios to all defaulted settings.

Please help! Thanks
3 answers Last reply
More about asus z170 usb pin working
  1. Do you see any devices in your CP that show as unidentified or driver not installed (little yellow triangle) ?

    If it's a known issue to be incompatible then it may not show up at all. Depending on the incompatibility issue.
  2. No. No, yellow issue sign or anything control panel.

    Asus told me to try the setup on another PC... I guess I'll have to try that.
  3. Bump.

    ASUS recommended I try the setup on another PC and it worked perfectly even without Corsair's Link software. Now the PC I tried it on had Windows 7, I've been reading maybe W10 might have something to do with USBs not working?

    FYI all of my External USB headers are working properly. I see no yellow triangle issues in device manager or anything.

    I'm wondering if Device Manager is even picking up the internal USB 2.0 (10-pin) headers?

    Device Manager shows:
    Universal Serial Bus controllers:
    -ASMedia USB Root Hub
    -ASMedia USB3.1 eXtensible Host Controller
    - Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)
    - USB Composite Device
    - USB Composite Device
    - USB Root Hub (USB 3.0)

    And that's it...
Ask a new question

Read More

Asus Device Manager USB