Solved

Ryzen 1700 at stock speed after loading windows

Just put together a new pc, trying to overclock it but having issues. When I boot it up and check the bios it shows my 1700 at 3.75ghz, but after windows loads it only shows 3.0ghz.

This was only an issue after the most recent windows update, but I'm not sure what changed to cause this behavior.

In addition, it messed up my RAM overclock. I had sucessfully got it running at 3066mhz but after the update it refuses to work any higher than 2800mhz (packaging says it should run at 3200mhz). It also appears that windows 10 does not fully shut down any more (I have fastboot disabled).

I've tried downloading chipset drivers from AMDs website but I get an NSIS error when I try to run them.

Is there anything I can do to try to fix this, other than reinstalling windows? I have a lot of games and I'd rather not reinstall them all.

Specs:
OS: Windows 10 Home
MB: MSI B350M Mortar Arctic, Bios v1.7
CPU: Ryzen 1700
RAM: Corsair Vengeance RGB 2x8GB 3200Mhz

Pretty sure these are irrelevant, but including them for sake of completeness:
GPU: EVGA GTX 780ti
PSU: EVGA Supernova G2 750w
6 answers Last reply Best Answer
More about ryzen 1700 stock speed loading windows
  1. Are you on the latest BIOS version, version 7A37vA7?

    Fluctuating core clocks are normal. Now, if it's MAXING out at 3Ghz, then that's a problem.

    Go into the control panel by typing "control" into the run command on the start menu. Go into the power options. Click on the change plan settings link next to your current power profile, which should be performance. If it is not, CHANGE it to performance, and then click the change plan settings link next to it.

    Click on change advanced power settings. Double click processor power management to expand it. Set min to 5% and max to 100%. Make sure cooling is set to active, which it should be.

    Save settings and exit. Restart and check operation now.

    If no change, shut down, pull the CMOS battery from the motherboard for two minutes, put it back, power up, go into bios and select the option to set default bios settings. Save settings, exit, check again.

    If it's ok then go back and reconfigure your custom bios settings for memory (XMP, AMP or custom settings), fan profiles and anything else you might want to be different than the default configuration based on your previous tweaking.

    What Windows version are you running?
  2. Yes, latest Bios (A7 is V1.7 for the mortar arctic).

    Yes, it was maxing out at 3.0ghz. Boost and xfr may have been working, but I did not attempt stress testing it in that condition and I did not see either one activate during normal use.

    I already adjusted my power settings as you described.

    I did not try clearing my CMOS by removing the battery, but I did do it by jumping the pins to clear it. I can try actually removing the battery too, though I'm not entirely sure how to get at it without removing hardware that is in the way, and thats going to take a lot of time. Is it safe to try removal with a flathead screwdriver instead?

    Not sure what windows version, but it was the most recent one from a couple of days ago, since Home edition has no way to disable automatic updates.

    I solved my own problem though, sort of. Fiddling with the voltages is again allowing me to overlock, though I'm still highly confused as to why a windows update would break what was previously a stable overclock at lower voltages (either that or something else happened and the windows update was pure coincidence). Any ideas?
  3. Best answer
    Eh, cmos jumper is just as good. Be sure to disconnect the PSU from the wall when you do it though and leave the jumper on for a few minutes. Also, pressing the power button for about ten seconds while it's in that state can't hurt either to discharge any residual energy that might still be hanging out inside the system.

    Then put it all back and go into the bios and choose the optimal default or setup default options. Save. Back into bios, set preferences, try it again in windows.

    I meant, as in windows 7, 8.1 or 10. I'm assuming 10.

    Might be a combination of bios update AND windows update. These damn f****ing Spectre and Meltdown patches have been causing all sorts of unexplainable issues on a variety of systems. Nobody seems to be immune and what affects one system with almost identical hardware might not affect the next one, depending on variations of installed applications, supporting hardware and motherboard model.

    Also, if you updated the bios AFTER you configured it originally with your overclock and memory settings, you would have to do it again all over after updating to the more recent bios. Overclocking and other custom settings generally don't STICK on newer bios UEFI systems like they did on some older systems. I used to be able to update the bios on my old ASUS Sabertooth 990FX R2.0 motherboard and would retain my OC settings through the update, or at least retain my preset OC configuration so I could reload it. My current Skylake system wipes EVERYTHING including saved bios configurations, so it has to be redone every time the bios is updated or of course, when reset.
  4. I specified Windows 10 Home edition in my original post. Not sure what update version, like I said.

    I updated the bios before overclocking. It refused to do anything other than stock speed before that (and 2133 or so for ram, which is default).

    Anyways, got it back to where it was before by increasing the voltages a bit. Still runs cool enough, so not worried about having to do that.

    Will mark your answer as solution. Does indeed seem to be an issue with updating things, unavoidable really. Updates causing issues is nothing new, but I've never run into one quite as odd as this. *shrug*
  5. You're right, you did. I missed it. Apologies.

    That IS incredibly weird, because NOTHING in Windows should affect the manually configured BIOS controlled voltage and multi settings, UNLESS you have a Windows based utility like AMD Overdrive or MSI Control center installed and have at some point configured settings using that which might override the Windows settings. If you DO have a desktop tweaking utility installed, and unless you are for some reason using it still, I'd uninstall it.

    Other than that, I can't imagine what might affect those settings other than something in the actual chipset driver package and it might be a good idea to figure out why you are unable to get that downloaded and try to do so along with installing the latest chipset drivers if there are any newer than what you have installed. Either way, good luck to you Estes.S.C.
  6. I uninstalled msi Gaming App and Ryzen Master and have not had any further issues with overclocking, seems one of them was causing issues, though I'm not sure why I didn't notice before the windows update. Sorry for the delay, it didnt occur to me to try this as I only used msi gaming app for rgb control, never touched any oc settings with either one.
Ask a new question

Read More

Overclocking Speed CPUs Motherboards AMD