Solved

Latest Intel Management Engine Components fails

Hi. I have installed the latest chipset drivers (ASUS HERO VIII MAXIMUS / BIOS 3703) but cannot install the latest IME Components (I believe this is the same as IMEI?).

Currently Installed

Intel Management Engine Interface: 11.7.0.1014 (DeviceManager\SystemDevices)
Intel Chipset Device Software: 10.1.1.44 (HKEY_LOCAL_MACHINE\SOFTWARE\Intel\InfInst)

Update that Fails:

Latest Version from ASUS 11.7.0.1040 MEI fails to install. During installation it's listed at IME Components 11.7.0.1043. When it fails I get the following in the log:

IntelME.log:

2018:01:17 11:57:59:806:   Return code: 1603
2018:01:17 11:57:59:806:   Aborting install
2018:01:17 11:57:59:807:   Updating ME Components size (ARP).
2018:01:17 11:57:59:808:   Error while setting estimated aplication size column: 2
2018:01:17 11:57:59:815:   Showing page: Error"


I've tried updating to the latest BIOS and rolling back the chipset drivers but nothing seems to stop the error above. Does anyone know how to get this to work? I signed up to ask on the ASUS ROG forums a week ago and still waiting for the moderators to ok the account. Hoping someone here can help.
5 answers Last reply Best Answer
More about latest intel management engine components fails
  1. Update your windows till latest point then try again.
  2. Robert Ban said:
    Update your windows till latest point then try again.


    Thanks but I have auto-updates enabled. I have just done a manual "check for updates" (tried earlier as well). Fully up to date but still the same issue
  3. Robert Ban said:


    I mentioned in my post that I'm already on the latest Intel Chipset Device Software (INF)
  4. Best answer
    Hmm i found this Hi. ASUS gave me the solution.
    1. You need update bios (3504) with *USB FlashBack Bios!!!!!!!!!!!
    2. After updating you need use CLR_CMOS
    3. Install Intel MEI driver on clear OS.*

    Guy has indentical motherboard as you
Ask a new question

Read More

Engine Chipsets Management Intel Components Asus