Asus Maximus IX Apex error 00 and 53

Hello everyone,
I built my own computer a month ago:
- Asus Maximus IX Apex
- Intel i7 7700K
- Gigabyte GeForce GTX 1060 6Gb
- XPG Spectrix ddr4 2x8Gb
- Deepcool Captain 240 EX
- Mars Gaming MPII 650W
- HDD Toshiba 3Tb

It worked fine for a month until now.
One day I turned it on but the screen was off, no video signal.
It starts but after 1-2 seconds appears on the motherboard the code 00 and then it restarts showing the code 53 (which means RAM problems).
I have tried almost everything, cmos reset, MemOK button, changed RAM slots and tried one by one, loosed the screws, but nothing.
I had my CPU tested by a specialist and he says it is okay.

Do you think I should change my motherboard?

PS: I do not hear any beep from the mobo, the led DRAM is permanently yellow; once I managed to enter the bios but had the same problem when rebooted the computer. The BIOS is updated via USB.
Reply to andreabonfante29
1 answer Last reply
More about asus maximus apex error
  1. Hi, Since CPU ok, then yes, I'd RMA the board.
    Reply to alexoiu
Ask a new question Answer

Read More

Asus Apex