My PC won't turn on when I press the power button

A couple weeks back I build a new pc to have at my stepdads place. It worked for about 4 days, but not when I try to turn it on it starts for a split second, (Fans starting, LED light turning on) and then shuts down again. If I press the power button again, right after this have happened, nothing happens at all. To make it start for a split second I have to unplug the power cord, press the power button, plug the power cord back in, and then press the power button.

I did hours of research online to find the issue but I just can't find it.
I have tried the following with no results:

1. Taking everything out of the computer and assembling it again.
2. Tested with only 1 stick of RAM, in both slots, then with the other stick, in both slots. The with both sticks, and switched them around too. (Basically every combination possible with 2 sticks of ram total)
3. Checked all pins on the CPU and Motherboard.
4. Checked to see if the motherboard standoff were placed correctly.
5. Starting with only essential parts
6. Double checked all manual and cables multiple times.

Those are what I can remember from the top of my head.
I also tried this: https://www.youtube.com/watch?v=5FWXgQSokF4 And I found out that my PSU was not functioning. So I send an email to the guys I bought the parts from, because they didn't have more of that PSU in stock so they gave me my money back. I then ordered a new PSU, plugged it in, changed all cables since this PSU had different cables (most likely because the two PSU's were from different brands). I then double checked everything. And started my computer. The exact same problem occured. The PC turned on with lights and fans for a split second, then off again. If I press again, nothing happens. I will then have to unplug the power cord, press the power button and replug the power cord. After this the computer starts for a split second if I press the power button.

Specs of the PC:
Motherboard: MSI LGA1151 H110M PRO-VH
CPU: Intel Core i3-7100 Kaby Lake Processor
RAM: Ballistix Sport DDR4 8GB RED x2
Harddrive: Seagate Barracuda 1TB 3.5" HDD
GPU: ASUS GeForce GTX 1050 Ti 4GB ROG Strix
First PSU: EVGA BQ 600W Hybrid Modular 80+ PSU
Second PSU: Corsair CX750M, 750W PSU - (The one currently in the build)

EDIT: I have a suspicion that it might be either the motherboard or CPU since I have not been able to test either of those. I can't think of a way to test the CPU and motherboard. So if you have any ideas on how to test either, I would love to know.
(I do not have another motherboard or CPU of the same socket laying around. So I can't test it with a new motherboard/CPU)
I want to be certain what the error is, before sending another email to the those I bought the parts from.
Reply to peterhbjoern
3 answers Last reply
More about turn press power button
  1. So the BIOS was updated before you got it??

    It would have needed a BIOS update for a Kaby Lake
    Reply to Paul NZ
  2. Paul NZ said:
    So the BIOS was updated before you got it??

    It would have needed a BIOS update for a Kaby Lake


    I got to the bios in the first 4 days of the pc working, made it download Windows 10 on my Hard Drive. That's pretty much all I did in the bios.
    Right now I don't even get to the bios, since the computer only turns on for a split second.
    Reply to peterhbjoern
  3. Dont know how it would have turned on in the first place. if the right BIOS wasn't on it to support the CPU

    You may have to take it to a local shop and ask them if they can update the BIOS with a Skylake CPU. Then install this CPU again

    See if it works
    Reply to Paul NZ
Ask a new question Answer