New HDD not showing

I just got a new Seagate Barracuda 2TB HDD to upgrade from my 500gb secondary drive. My primary is am SSD. Installing the new HDD, it shows up in bios (MSI 990FXA Gaming mobo) on the board explorer. It shows up in the device manager as its model number with 1.81TB of storage, this device is working properly. It does not show up in explorer or disk management at all. I can't format it or use it. At one point it was showing up under the storage pool whatsit. I started using that but cancelled after I realized that wasn't windows 10 speak for formatting and allocating.

I've tried on different SATA ports, different cables, nothing.

The only thing I can think of aside from dead drive is the orientation. I don't have it mounted in the cage yet due to cable constraints and the fact that it will replace the spindle currently in the cage. It's standing on end with cables pointing up, but as I understand position shouldn't affect it. Am I wrong?
Reply to Sanityfree
3 answers Last reply
More about hdd showing
  1. You need to assign a drive letter and create a partition in disk management before it is usable.

    http://knowledge.seagate.com/articles/en_US/FAQ/188931en?language=en_US
    Reply to darkbreeze
  2. As I said, it does not show up in disk management.
    Reply to Sanityfree
  3. Figured it out. When I halfway created the storage pool, windows tied up the entire drive in it, hiding it from other uses.
    Reply to Sanityfree
Ask a new question Answer

Read More

Storage Hard Drives