Solved

After upgrading to new motherboard, LAN and wireless no longer work

I upgraded to an Asus B350 F gaming and Ryzen 3 1200. I installed the drivers on the installation disk and found that I could not connect to either wireless or wired networks. The issue was present before the installation of the drivers. With wireless, Windows will show that I am connected and return no errors but I am unable to connect to websites. After attempting to install Intel's LAN drivers from Intel's and Asus's websites, the installation would not complete. I updated the BIOS from 0805 to 0809 to no avail. Any thoughts?
Reply to pugsofwrath
7 answers Last reply Best Answer
More about upgrading motherboard lan wireless longer work
  1. On another computer click these links, they are a direct download to the LAN drivers. Put it onto a flashdrive, and just put the drive into your pc and just do the setup.
    http://dlcdnet.asus.com/pub/ASUS/mb/04LAN/IntelLAN22.4.16.0_RS2_20170718.zip

    And for wireless not working, it probably doesn't come with a built in wireless card.
    Reply to Saturnity
  2. You can try resetting your network stack ... but it kinda sounds like you have a driver conflict going on.
    Reply to anotherdrew
  3. Best answer
    When you upgraded from your old system with the new components, did you reinstall Windows after you upgraded everything?

    If not, I'm pretty sure that would fix your problems.
    Reply to ThatVietGuy
  4. Saturnity said:
    On another computer click these links, they are a direct download to the LAN drivers. Put it onto a flashdrive, and just put the drive into your pc and just do the setup.
    http://dlcdnet.asus.com/pub/ASUS/mb/04LAN/IntelLAN22.4.16.0_RS2_20170718.zip

    And for wireless not working, it probably doesn't come with a built in wireless card.


    I forgot to mention that I have a wireless card. I already downloaded the drivers directly from Asus.
    Reply to pugsofwrath
  5. ThatVietGuy said:
    When you upgraded from your old system with the new components, did you reinstall Windows after you upgraded everything?

    If not, I'm pretty sure that would fix your problems.


    I'll try this tomorrow when I have some more time.
    Reply to pugsofwrath
  6. I had a similar issue after upgrading from Win 10 v1703 to Win 10 v1709 ( Fall creators edition). After upgrading, my LAN and WLAN did not work, even after installing latest drivers. I had to roll back to 1703 for everything to work. This was on a a Lenovo x260, my pc at home however does not have any issues after upgrading to 1709. Just my 2cents.
    Reply to GR1M_ZA
  7. ThatVietGuy said:
    When you upgraded from your old system with the new components, did you reinstall Windows after you upgraded everything?

    If not, I'm pretty sure that would fix your problems.


    Reinstalled Windows and the issue was resolved.
    Reply to pugsofwrath
Ask a new question Answer

Read More

Wireless Asus Drivers Motherboards