Z370 extreme4 won't pre POST

I just finished updating my rig and it won't even think about booting :/ I used the same PSU in my last build and it was working fine so I don't think that's the issue. I triple checked the 24 and 8 pin power cables are plugged in and also made sure the front panel power is plugged in correctly. Also I am using the same case as before and the power button on the case worked. Interestingly there is a blue LED the is blinking on the I/O shroud but that all that happens. This happens when I turn the PSU on. Any ideas??? Hoping the mobo isn't DOA and I just forgot something stupid.
Reply to julianrodriguezroost
4 answers Last reply
More about z370 extreme4 pre post
  1. Did you install the standoffs? Connect the cpu fan?
    Reply to Paul NZ
  2. Paul NZ said:
    Did you install the standoffs? Connect the cpu fan?


    Yes and yes
    Reply to julianrodriguezroost
  3. And the systems specs are?
    Reply to bignastyid
  4. So I figured it out. Took everything apart and got the mobo to boot outta the case so no DOA. plugged everything in one at a time to make sure it would boot. The only problem was my USB 2.0 header for the case that worked fine in my previous build. I have no idea why this is an issue but idc about USB 2.0
    Reply to julianrodriguezroost
Ask a new question Answer