Ryzen 3 1200 Gigabyte mobo

I recently upgraded my computer parts due to old computer being 3 years old. I have the following parts

8GB (1x8GB) Crucial Ballistix Sport LT 2400MHz DDR4 - White

ASUS NVIDIA GeForce GTX 1060 DUAL O.C. 6GB - Graphics Card

1TB Seagate Barracuda Hard Drive 3.5" SATA III - ST1000DM003

GIGABYTE AB350 Gaming 3 - AMD RYZEN Motherboard

AMD Ryzen 3 1200 Quad Core AM4 CPU/Processor with Wraith Stealth Cooler

600W - EVGA 80 PLUS White Cert Power Supply

BitFenix Comrade Midi-Tower - Black


My computer won't post and there is a red cpu light on the motherboard. I sent this back to the company I bought it from for them to check pins and update the bios, they did, had windows 10 running and sent me it back. However, it still won't work for me. I connect everything right, all the parts are new and all the parts work with another motherboard, cpu and ram. I've done a skeleton build with bare minimum, on top of a box to make sure the case wasn't shorting the motherboard, still red cpu light.

I've cleared cmos and left the battery out multiple times and that did nothing too.

I'm completely out of ideas, the on-board graphics doesn't work because my cpu doesn't support it and even then it doesn't post at all!
Reply to jermain196byut
4 answers Last reply
More about ryzen 1200 gigabyte mobo
  1. Try testing different power supply.
    Reply to alexoiu
  2. The power supply is new and works with my older computer components, but I tried an older 500W power supply and I still get the same.
    Reply to jermain196byut
  3. That board needs a BIOS update to use that processor.
    It needs the latest F7 version.
    http://www.gigabyte.us/Motherboard/GA-AB350-Gaming-3-rev-10#support-cpu
    Reply to Zerk2012
Ask a new question Answer

Read More

Computers Gigabyte