ASUS RX460 2 GB wo'nt work with Win7-64Bit-Radeon-Software-Adrenalin-Edition-17.12.2-Dec19

Hello,

I have bought a new Asus RX 460 card, and tried to install it to my system. After 2 days of "dancing" rx 460 start to work with old driver Non-WHQL-Win7-64Bit-Radeon-Software-Crimson-16.11.3-Nov8.

When I try to update existing driver to Win7-64Bit-Radeon-Software-Adrenalin-Edition-17.12.2-Dec19 in Windows 7, system tries it but in the Devices manager I got a error: System found driver but something wrong, video card was stopped with 43 error and please go to the manufacturer's website and download a drivers from there.

And after finish of the installation of the new driver - I see a RX 460 Series with exclamation mark in the Devices manager.

Before RX 460 started work I did the next:

1. Updated BIOS ( I have UEFI BIOS).
2. Installed chipset and VGA drivers for my integrated VGA card
3. Installed all critical updates on Windows 7
4. Deleted all AMD drivers with AMD Uninstall tool
5. And manually installed the old driver via Device manager.

So, the question why drivers can't be updated to the fresh ones?

My specs:

i5 2500
550 watts
12 GB DDR3
Windows 7 64 bit
Asus PCI-Ex Radeon RX 460 2GB (DUAL-RX460-O2G)
Motherboard Asus P8Z68-V LX
3 answers Last reply
More about asus rx460 work win7 64bit radeon software adrenalin edition dec19
  1. Works fine here. Did you try uninstalling drivers with DDU ? http://www.guru3d.com/files-details/display-driver-uninstaller-download.html
  2. Tried recently. Booted in to the Safe mode, deleted AMD drivers there via DDU, rebooted and installed win7-64bit-radeon-software-adrenalin-edition-17.12.2-dec19. After reboot the same issue: I see a RX 460 Series with exclamation mark in the Devices manager.

    Any other solutions??
  3. Solved. By installing the last driver from AMD + patched it.
Ask a new question

Read More

Asus Radeon Software