MSI z370 won't boot after enabling game boost

I have a Z370 mobo with a I8700 CPU. I tried the game boost mode and after fisrt login to Windows everything seemed right. After I disabled the game boost my pc won't boot. I tried to flash the mobo by removing the battery for at least 3 minutes. The settings went back to normal but my pc won't boot Windows. Starts to do some automatic repairs but can't do anything. Please help!
Reply to tasos_lu
2 answers Last reply
More about msi z370 boot enabling game boost
  1. 1| Make sure the boot device priority has Windows Boot Manager as the primary drive.
    2| If you have nothing of value on the OS partition, you could reinstall it since most often the automatic repair or restore options fail to reach/meet the intended purpose.
    3| You may want to share your full system's specs like so:
    CPU:
    Motherboard:
    Ram:
    SSD/HDD:
    GPU:
    PSU:
    Chassis:
    OS: Windows 10
    Reply to Lutfij
  2. MY system's specs are:
    CPU: i7 8700
    Motherboard: MSI z370 Gaming Plus
    Ram: 16g Corsair vengeance
    SSD/HDD: Samsung 850pro 256g
    GPU: Sapphire HD7950OC
    PSU: 600W
    Chassis: Coolermaster full tower
    OS: Windows 10 ultimate 64bit.
    Reply to tasos_lu
Ask a new question Answer