PC not booting - stuck on splash screen or displaying "please select proper boot device" message

I came home from work to find that my PC no longer boots (posting this from work!).

What I encounter on firing up my machine is the CPU fan going 100%, the Gigabyte splash screen appears with the usual options to go to Bios/select boot drive etc. But then these options disappear and I'm left with a noisy computer and the splash screen.

Alternatively, if I choose the option to select which drive to boot from and then physically choose my SSD (I saw both "Windows boot manager followed by my SSD name, and also my SSD name by itself), I go to the black screen telling my to "please select proper boot device" and reboot the machine. I had attempted to set the boot order in my MoBo bios options also with no effect.

I have unplugged everything from the MoBo except for USB mouse and PS2 keyboard and tried re-seating the GPU and SSD (both power and changing Sata cable), but still no luck.

I plugged the SSD into my brother's PC, booting his like normal so that I could explore my drive to check that it isn't corrupted, and it appears to in fully working order, so I took the opportunity to back up all of my important documents.

Possible culprit
I recently bought the following bluetooth dongle from Amazon and installed it along with its driver the night previous to my problems.

The only thing I can see going wrong is the fact that, when going to sleep I kept my PC in Sleep mode but the dongle was still flashing blue - so I pulled it out of the USB port whilst the PC was still sleeping. I know this won't make the SSD corrupt or anything, just wondering if the Driver install etc may mess things up

If anybody has any information regarding what may be wrong and whether I can salvage things without resorting to a wipe and clean install of Windows, I'd be thrilled!

Tech specs
Motherboard: Gigabyte F2A68HM-HD2 AMD FM2+ Micro ATX
CPU: AMD Athlon X4 860K Black Edition 3.70GHz (Socket FM2) Kaveri Quad Core
SSD: SanDisk SSD PLUS 960 GB
Reply to physicsboy
5 answers Last reply
More about booting stuck splash screen displaying select proper boot device message
  1. The BT dongle. I think it's normal if it flashes blue. I use one too. It flashes even if it's off.
    Reply to Paul NZ
  2. Paul NZ said:
    The BT dongle. I think it's normal if it flashes blue. I use one too. It flashes even if it's off.


    Hi Paul,
    Yes I know that this is what the dongle will do. I just wanted it to stop flashing for the night so pulled it out while still in sleep mode.
    Just wondering if my actions either pulling it out or actually installing the driver may have caused problems?
    Reply to physicsboy
  3. Nope I dont think it'll cause probs


    Disable the logo in the bios so you can see what it's saying / doing on the screen when you turn it on. Why it's stopping
    Reply to Paul NZ
  4. Paul NZ said:
    Nope I dont think it'll cause probs


    Disable the logo in the bios so you can see what it's saying / doing on the screen when you turn it on. Why it's stopping



    I will have to try this out later when I get home. I didn't think there would be anything behind the Splash.
    Reply to physicsboy
  5. Paul NZ said:
    Nope I dont think it'll cause probs


    Disable the logo in the bios so you can see what it's saying / doing on the screen when you turn it on. Why it's stopping



    I couldn't find a solution after removing the logo from the start up screen, so I had to resort to reinstalling windows which was again, a complete faff.

    It looks like there was an issue with my SSD being in MTG format, although it has been in this format since I built it over a year ago with no troubles.

    After reinstalling windows everything loads as normal. Although I am yet to install the driver for the bluetooth dongle again, so I will be looking forward to potentially having to go through the whole rigmarole again in the near future!
    Reply to physicsboy
Ask a new question Answer

Read More

Boot Motherboards Splash Screen