Second SSD (Non-Boot Drive) Prevents My Computer From Booting. Is my second SSD corrupt?

I have two SSDs. One is a Samsung Evo and the other is a Mushkin Reactor. The evo is my boot drive (windows) and the reactor is my extra storage, D:, drive. I had Ubuntu running through a virtual machine installed on the reactor SSD and was working in that environment. When I tried copying some files from my Windows to Ubuntu (through the VM), my entire system locked up and I was forced to hard shut down my system. Now, when I try to boot up, the system stays locked at the BIOS splashscreen preventing me from entering the BIOS and Windows.

So, I tried unplugging my reactor SSD from the system (while it was off) and the system successfully boots into Windows. But whenever the reactor SSD is plugged in, the system refuses to boot past the BIOS splashscreen.

When I try reading the reactor SSD externally using a SATA to USB adapter, Windows file explorer becomes unresponsive until it "finishes" reading the reactor SSD, at which point I can see the root folders that were previously present in the drive, but cannot access them since a prompt pops up saying "Drive not ready".

I have verified that my samsung drive is the first boot priority, the system is in AHCI mode, cables and connections are fine as the samsung SSD boots properly when I try the other SATA and power cables. I also tried booting with fast boot off and hot plugging in the reactor drive with no success.

Since I was able to see root folders of the SSD, but not open them, is my SSD corrupt?
And why does my system lockup whenever it is connected to the motherboard, even though it is not the boot drive?

I appreciate any help. Thanks.

Note:
I built my computer, September 2016, so all the parts should be in good health.
ASUS Z170I Pro Gaming
6700K
GTX 1060
Reply to calvinhu9
No answers Last reply
More about ssd boot drive prevents computer booting ssd corrupt
Ask a new question Answer

Read More

SSD Boot Problem Windows Boot Boot Failure BIOS Corrupt SSD SSD Problems SSD