Asus Maximus VIII Hero No Display

Hey guys, so I have been trying upgrade my PC. I have all new parts except for my 500w power supply, 1 TB drive, and my GTX 950(will be replaced with a 1070 TI eventually). I got the Asus Maximus VIII Hero motherboard, I7-7700k Kaby Lake CPU with H75 liquid cooling, and 16 gigs of DDR4 ram(2 sticks). I put all of it together and everything ran as expected, except for display. Everything boots up normally and POSTs on startup. All fans are running and everything is pushed down and running. I have checked and the HDMI cable is not the problem. I have spent a week trying to remove everything piece by piece seeing what worked and what didn't. I recently found out tonight that the BIOS needs to be updated to be compatible with my CPU. I did the flashback but I don't think it worked correctly. I downloaded the latest BIOS update from ASUS along with the renamer. I formatted my 32 gig USB to fat32 and plugged and turned on my power supply, and the power supply only. I pressed down the button until it started flashing then let go. It flashed for a few seconds then turned to a solid blue color, which means something is wrong. I have tried taking everything out, even the CPU, but to no avail. The Q-Code is and always has been 00. I am at a loss, any help would be greatly appreciated.
Reply to maxshim1325
1 answer Last reply
More about asus maximus viii hero display
  1. When you do the USB BIOS flashback, you have to remove all the components, connect the PSU to the MB with 24-pin and 8-pin cables only. I add the linker for how to. Try clear the CMOS firts, then try it (USB BIOS flashback) again.
    https://www.youtube.com/watch?v=JVvHwq3syqI

    If it still does not work, you may need the new BIOS chipset, or contact asus.
    Reply to cin19
Ask a new question Answer

Read More

Asus Power Supplies Displays Motherboards