Solved

PC Ryzen not switching on. Memory not compatible?

Hello,

I just bought a new set for the Ryzen CPU, and tried to mount it today.

The set is:
Ryzen 1800x
ASRock x370 Killer SLI
GAMMAXX 400 cpu cooler
RAM: (only one stick of) HyperX 8gb DDR4 2400Mhz model HX424C15FB2/8
Gigabyte GeForce GTX 1050 TI 4GB (with just one cooler and no need for power cable)

Thing is, everything seems to be working, fans are rolling, LEDs... but I'm getting no image on my screen. Not even the booting screen. I also do have a speaker, installed, but I get no error beep code or any beep at all.

After hours and hours and hours, spending delving on what it could be, I came to the conclusion that maybe my RAM memory would not be compatible and thus be causing the issue.

I tried on different screens and with both DVI and HDMI. None worked.

Could you confirm this? My memory is a HyperX Fury 8gb 2400Mhz - HX424C15FB2/8. While there are memories very close to this number above, this one (exactly) is not...

Could be that this is the culprit? Like, does it sound that a non compatible memory would cause the system to run everything, apparently, but not show any image on the screen?

I first suspected the Video Card, but it's all perfectly set there.

I would hope for a fix without it being memory related, as it is soooo expensive and difficult to find a model that would serve...

Thanks.

EDIT: PCPartPicker, though, says it's compatible... https://pcpartpicker.com/list/TMzj3F
Reply to gukre
17 answers Last reply Best Answer
More about ryzen switching memory compatible
  1. which slot did you put the ram in?
    Reply to vapour
  2. Looking at the manual, if mb looks like this:

    CPU, ram slot 1,2,3,4

    You should put that single stick in #2 slot.
    Reply to vapour
  3. Hmm...now I put on the 2nd slot, it gave me a 3 short beeps code. Better or worse?
    Reply to gukre
  4. 3 short beeps Basic memory 64K address check error
    https://ddr4motherboard.com/beepcodes/ASROCK-X370-KILLER-SLI-AC

    So memory can not function for sure. BTW, how come only 8gb ram for 1800X... 2400 is too slow. 3000+ 16gb dual channel is preferred...

    two possibility: ram or MB

    turn off pc and psu, clear cmos battery, reseat the ram again, make sure it sits well and retry.
    Reply to vapour
  5. Well, I got it to work (for the moment)!!

    Unfortunately, clearing the CMOS did not work. Took out the battery also... No sign of life. At one moment it gave me a bizarre 11 beeps, 3 short ones, a very brief pause, then another 8 short ones.

    So I decided to give one lost effort for the day, and take the motherboard out of the case and mount just the necessary, and put the RAM on the last slot (don't know why, it was just the further from the cpu, so I just put it there).

    So I just left the cpu and fan, memory, VGA and the cable to turn the pc on and off (no SATA, no chassis fan, no SSD, HDD, no mouse and keyboard...). It lit up and when I looked up to the monitor, there it was, on the bios screen!!

    Don't know what made it work.
    I suspect I may have installed the memory AFTER the motherboard was on the case, but I'm not sure if that was the case when I first installed, and then it was not secure.

    This time, I too the memory out and did put it while the mobo was outside, on a perfect flat surface, where I could apply enough force to click it good.

    So, for now, the mobo is outside. Tomorrow I'll look better into it and put it inside the case, and pray that it keeps going!!

    Thanks ppl
    Reply to gukre
  6. Ah, and why just 8gb RAM... Have you seen the prices?
    And it's difficult to find, they are all out of stock. I'm living in Brazil and here it's mostly all gone.

    I chose this because I can get another similar in Germany, this coming January, to make it 2x8gb
    Reply to gukre
  7. don't... two separate sticks will very likely not work... even for same model, there is a possibility not working together. stick to 8 gb for now and buy 2x8 in a pack and sell the single stick later on...

    Congrats!
    Reply to vapour
  8. Hmm. Ok keep that in mind then!

    Now, everything seemed ok. But now I'm stuck since my keyboard AND mouse won't work on Windows. Both work on the BIOS, but as soon as it goes into Windows they do not work anymore.
    Tried going into safemode, nothing.

    I cannot even go to device manager to check it out...
    I'm running Windows 7, and I don't have a CD or DVD thingy...

    Tried switching off pc, taking out USB cables, etc.

    And I thought the saga was over. Oh my.

    Help?
    Reply to gukre
  9. buy or borrow a ps/2 keyboard :) win 7 does not have usb driver included, unlike win 10. Once you have the ps/2 keyboard, use tab etc to install usb driver first from motherboard website
    Reply to vapour
  10. Thanks! I went out and got myself an adaptor USB-PS/2 and it did the job! Partially...

    Everything good, I opened up chrome to go get all drivers... No internet... The Ethernet cable is not being recognized.
    So I got no internet... Nothing works!

    And it's working. I was able to update my bios thorough the internet and bios itself.
    Reply to gukre
  11. Congrats! Enjoy new pc ;)
    Reply to vapour
  12. Thanks vapour, but it's not yet enjoyable... Everyone says, go to the website and download the drivers, but the pc had the yellow exclamation point on the device manager for Ethernet, and thus I can't go online and download anything... So I'm stuck here.

    You have an idea?
    Reply to gukre
  13. Best answer
  14. Thanks vapour, but the problem is:
    - it does not recognize my Ethernet cable.
    - I tried a wireless adaptor, also not recognized
    - I tried an external HDD, not recognized on Windows Explorer

    So, I can't think of a way to load the drivers onto my pc
    Reply to gukre
  15. ha, been there just several months ago when I was building :)
    Reboot with whatever media you used to install windows, plug in external hdd, pick repair and you will have a choice of cmd. Find your external hdd in cmd and copy the driver over onto pc, reboot, install. command example:
    copy H:\drivers C:\
    Reply to vapour
  16. Hmm, I thought I had replied with the solution to this whole saga, but I think it did not go.

    Well, it's finally working (apparently) good.
    But what I had to do was make a bootable USB with Windows 10 on it. Thankfully I had 1 USB 2.0, because it would not work on 3.0.

    I tried using an old DVD Drive I had, but out was soooo slow, it was not possible to install any driver from it.

    So I gave up and installed Windows 10 by booting the system through the USB stick and did a new install.

    But first I installed my other HDD internal SATA and backuped some files from my main SSD, because it was going to be formatted.

    After this, it was a breeze. Windows installed fine, no hiccups, internet, keyboard, mouse, screen worked from the get go. Easy.

    Now I just need to get it all inside the case and hope out strays all good. Those things are very sentimental!!

    Thanks vapour!
    Reply to gukre
  17. Cheers, mate :)
    Reply to vapour
Ask a new question Answer

Read More

Memory Graphics Cards ASrock Motherboards Compatibility