Solved

ASRock x370 not booting

So my new am4 motherboard gives me no signal , USBs work for a split second and then power stops flowing through the usb.now to eliminate issues I have : changed my h115i ( with am4 bracket) for a spare wraith cooler , I have switched RAM , PSU powering my AM3 motherboard to boot (100o watts), I have booted my 1800x on another PC so it's not the cpu, switched GPU, computer boots and motherboard seems to respond to power as the motherboard turns on and gives off red LED light , both power pin connectors are in place , I have reset ( or tried ) to reset CMOS by removing the battery and jumping it. The motherboard it self has a HDMI port but that does not.give signal.the PC it's fully powered untill I turn it off. At this moment I have an RMA for the board, I have never asked for help but I'm kinda in a situation but I feel like if anything you are my last hope oh great PC master race please help this pleb game again ....
Reply to dreategui8998
7 answers Last reply Best Answer
More about asrock x370 booting
  1. Best answer
  2. alexoiu said:


    I have not tried the DVI and or VGA inputs everything alse I think I covered . I'll try when I get home . Weird if this happens to be true that shame on ASRock , I built my lil Bros PC with an Asus motherboard and it booted right of HDMI. I'll let y'all know
    Reply to dreategui8998
  3. alexoiu said:


    Soo..... I only happen to have a DVI connector so I installed that into my Titan and the monitor and no cable connected appears , all the gpu I own all have HDMI and DVI . My monitor does support VGA but again nothing I own uses VGA.
    Reply to dreategui8998
  4. Try borrowing a monitor and testing.
    Reply to alexoiu
  5. alexoiu said:
    Try borrowing a monitor and testing.


    I borrowed a monitor still no signal. So I tried my monitor that has VGA , I bought a extension for VGA and attached it to my DVI cable and the monitor booted and took me to desktop all USB working I updated bios and other minor updates from the ASRock site , it restart it twice for the updates and then I decided to turn it off by shutting it down , added the m.2 ssd sound card and then.........no signal again .. so I took those off again put the VGA extension I bought of some very shady guy and again ......no signal, but for those 10 minutes I checked cpuz and it recognized everything , I'ma switch graphics card again ...
    Reply to dreategui8998
  6. alexoiu said:
    Try borrowing a monitor and testing.


    Yeah no gpu is same issue . It randomly works on and off makes me think it's shorting out but everything seems proper . U s been 4 business days now and Asrock has not updated my email , I call them today and the RMA department was out for the day 3 on Pacific Time . I'm so mad RightNow I should have went Asus Mobo their stuff is plug and play no issues. I guess this is my first faulty board , ....... -_-; it's Soo stressfully I'ma switch to my AM3 100% I'm sure I'll work . Dammit many screw ASRock if they don't call me I'll call them in the morning demand a refund screw the RMA I'm sure it's cheaper for them to refund , then to send another board from Europe I'd cares less if they give me Newegg credits .
    Reply to dreategui8998
  7. I sent Mobo to ASRock........
    Reply to dreategui8998
Ask a new question Answer

Read More

Gaming ASrock USB Motherboards Power