Solved

No POST, No Display, red LED right near RAM. Just got Brand New Motherboard but PC doesn't boot.

In 2014, I purchased parts for my first gaming PC. To this date, it has worked with no problems whatsoever. However, recently I hit the power button on my surge protector and now it won't boot up. Specifically speaking, all the fans move and every part works except a red led light on my Asus Sabertooth Z87. When I looked in the manual, the light represents the CPU LED. I RMA my motherboard for exact same model and the same thing is happening. Before I concluded that the CPU was the problem, (because it is very unlikely for a CPU to die) I did a paperclip test with my PSU which worked as well as a CMOS reset with the jumper and battery. Any input regarding this matter would be greatly appreciated as I am at a loss for words because my warranty literally just expired months ago. I know this may be asking much but if anyone has like a spare lga 1150 socket cpu i could test for just a cheap price that no one is using, it would help a lot.
3 answers Last reply Best Answer
More about post display red led ram brand motherboard boot
  1. Your PSU may power up, but doesn't mean it's working correctly.

    Do you have another PSU to test with on the system?
  2. neatfeatguy said:
    Your PSU may power up, but doesn't mean it's working correctly.

    Do you have another PSU to test with on the system?

    Unfortunately, no. I will be borrowing a friend's psu within the upcoming days but I am more inclined to attribute the problem towards the cpu due to the nature I have described.
  3. Best answer
Ask a new question

Read More

LED Monitor Motherboards