PC doesn't turn on

I've been having an intermittent issue with my pc not turning on. This is a custom built high end pc, maybe 7 years old.

Fractal design case
Intel 3930k
Asus Sabertooth mobo
64gb ram
Xfx pro 1250 watt PSU
128 boot ssd
2tb data drive

Issue started several months ago with the pc not turning on occasionally. Had to unplug the power cable and it would come up. Now I can't seem to get it on at all. The mobo has a green light on it so I know it's getting power. I switched out the PSU with a brand new one and it still doesn't turn on.

Any ideas?
Reply to lashole
8 answers Last reply
More about turn
  1. Please post your full system spec.
    Reply to Barty1884
  2. have you swapped cmos battery on newer mb if they go bad some mb wont post.
    Reply to smorizio
  3. Don't think it's the CMOS as it doesn't even boot. Though I could always steal one from work and see what happens. Picture flipping a light switch and with the bulb being burnt out. That's kinda what is going on now. I have ZERO of evidence of power minus the green status light on the mobo.

    If it was a bad mobo, I don't tHink I'd get the green light. If it was the PSU, the replacement would have solved the issue. Just as an fyi, I have reseated all internal power connections.
    Has anyone ever a problem with the power switch on the case physically going bad?
    Reply to lashole
  4. if it the power or reset switch you think is bad just pull the switch from the mb and use a screw driver to short the pins. why i say cmos battery is the power switch on a case is just an eletroinic switch. that changed one of the 5v legs, if the cmos battery is dead then the cmos cant post the mb when it sees power on it.
    Reply to smorizio
  5. smorizio said:
    if it the power or reset switch you think is bad just pull the switch from the mb and use a screw driver to short the pins. why i say cmos battery is the power switch on a case is just an eletroinic switch. that changed one of the 5v legs, if the cmos battery is dead then the cmos cant post the mb when it sees power on it.

    I pulled the cmos and got one boot up, this was after re seating all the cables. I powered it down and can't turn it on again.
    I tried to use a screwdriver to short the pins and it doesn't turn on either. I'm completely stumped here.
    Reply to lashole
  6. try a new cmos battery cr203. there two pack thta most stores have. if it not the battery try a test power supply.
    Reply to smorizio
  7. smorizio said:
    try a new cmos battery cr203. there two pack thta most stores have. if it not the battery try a test power supply.


    Damn it. I accidentally marked this as best answer. My original post said that i tried a new power supply. That did not work. I will try a new CMOS battery later. And will update later.

    Does anyone know how much power should be coming off the power switch pins on the mobo? Mobo is x79 Sabertooth.
    Reply to lashole
Ask a new question Answer