Intel Mtherboard DQ67SW booting issue

Hi to all
I'm putting together gaming system for a friend. Can't get the motherboard to boot from a hard drive. Every time after reset it goes to bios by itself. Does not react to keyboard shortcuts F2 F7 F10 if jumper is set in 'normal' mode, only when set to 'config'. Updated bios to latest 0068 version. Tried many different options in bios, no luck. Don't know what other info you guys need to help me identify problem.

Spec.
Mobo: Intel DQ67SW
CPU: i7 2600 non K
RAM: 2x BLT4G3D1869DT1TX0.16FMR
HDD: Toshiba HDWD 120

Thank you
Reply to jonrambo484
3 answers Last reply
More about intel mtherboard dq67sw booting issue
  1. There are a couple of issues here.

    First, your inability to interact with BIOS using the keyboard could be due to any number of issues. If you are using a USB 3.0 or wireless keyboard, sometimes the BIOS does not load the drivers for that until after the OS boots. If you are using either of those, try using a standard USB 2.0 wired keyboard. That should solve that issue.

    Second, check to make sure that the BIOS can see the hard drive. If it can, go into the boot order and make sure that the hard drive is the first device that it tries to boot to. By default, the CD Drive is the first device most BIOS try to boot to, but I would try to override that for troubleshooting purposes in this case. Hope this helps.
    Reply to austintx1985
  2. mobo has usb 2.0 and 3.0, i've tried every single one
    keyboard is wired; logitech g410
    bios sees the hdd, i've tried to set as a first device too boot from, no luck :( ; i've even switched every oyher devices off to make sure the hdd is the only one the motherboard can boot from
    also forgot to mention; motherboard does not give any error beeps or error messages during post, just goes to straight to bios not even trying to boot from hdd; checked the drive in other system, it works ok ( its a new drive by the way)

    I thought motherboard from intel will be trouble free compared to gigabyte, msi, asus and other brand; was WRONG; regret the purchase now
    Reply to jonrambo484
  3. See if you can make a bootable USB drive with Ubuntu or something on it, and see if you can boot into that. If the answer is still no, I would suggest contacting either the place you purchased the board from to see about a return/replacement, or Intel to get an RMA put in to get the issue fixed.
    Reply to austintx1985
Ask a new question Answer

Read More

BIOS Boot Hard Drives Motherboards