GTX 1070 not preforming like it should

hello everyone I have my Nvidea Gtx 1070 for a year right now. But i never got the performance I expected from it. I searched trough a lot of forums and eventually gave up. Until I recently noticed that my GPU either maxed out at 4 gB vram or didn't do anything(GPU usage below 10%) Does anybody knows how to fix this or give me more fps in games thanks ;)

watch dogs everything low: 0-20 fps.
just cause 3: 0-3 fps.
(in just cause my GPU usage didn't even go up to 4%(in watch dogs my usage went up to 60% but the vram never went higher then 4 gb))
(also cpu sits at 50% while "gaming")
Reply to jamie.calmeyn
16 answers Last reply
More about gtx 1070 preforming
  1. How do you even keep a card for a year when it runs so bad??
    Did you install proper drivers from the Nvidia website? Is your PSU good quality 500W minimum? Did you plug the PCI-E connector into the GPU to give it power? Are you using adapters instead of a single 8 pin connector?
    Reply to Cioby
  2. Whats the rest of your specs? Are you sure your monitor is plugged into your GPU and not the motherboard?
    Reply to Snipergod87
  3. Cioby said:
    How do you even keep a card for a year when it runs so bad??
    Did you install proper drivers from the Nvidia website? Is your PSU good quality 500W minimum? Did you plug the PCI-E connector into the GPU to give it power? Are you using adapters instead of a single 8 pin connector?


    i always download the newest drivers. I have a 750W PSU and yes i did plug them in. and no I didn't use any adapters
    Reply to jamie.calmeyn
  4. Snipergod87 said:
    Whats the rest of your specs? Are you sure your monitor is plugged into your GPU and not the motherboard?


    CPU: I7 4790K
    Ram: 16gigs DDR3
    MOBO: Z97 gaming 5
    PSU: 750W


    and yes it is plugged in in to my GPU
    Reply to jamie.calmeyn
  5. Did you get the application from your specific manufacturer if you have a custom cooler GPU, like MSI ASUS Gigabyte. Google the 1070 card that you have and check the official site of the company. Go to support or donwload and check any bios updates or apps.

    Also before you installed this card, did you have another card? Did you do a DDU clean install of the new card and remove everything else before installing the new drivers?
    Reply to Cioby
  6. Cioby said:
    Did you get the application from your specific manufacturer if you have a custom cooler GPU, like MSI ASUS Gigabyte. Google the 1070 card that you have and check the official site of the company. Go to support or donwload and check any bios updates or apps.

    Also before you installed this card, did you have another card? Did you do a DDU clean install of the new card and remove everything else before installing the new drivers?


    Hmm. gonne try that. I have a MSI GTX 1070 Gaming X 8g.
    Before i had this GPU i was using intel integrated graphics.
    Reply to jamie.calmeyn
  7. You could even try uninstalling the Intel GPU driver. And do a new clean install + the apps from MSI page.
    Reply to Cioby
  8. Cioby said:
    You could even try uninstalling the Intel GPU driver. And do a new clean install + the apps from MSI page.


    ok. gonna try that a soon as possible
    Reply to jamie.calmeyn
  9. Cioby said:
    Did you get the application from your specific manufacturer if you have a custom cooler GPU, like MSI ASUS Gigabyte. Google the 1070 card that you have and check the official site of the company. Go to support or donwload and check any bios updates or apps.

    Also before you installed this card, did you have another card? Did you do a DDU clean install of the new card and remove everything else before installing the new drivers?


    ok. so i instaled the driver and I got 5 more fps in watch dogs on low settings lol
    Reply to jamie.calmeyn
  10. What's your resolution? 5-25 fps is still bad
    Reply to Cioby
  11. Cioby said:
    What's your resolution? 5-25 fps is still bad


    quit low gonna upgrade in 2 weeks or so now its 1440x 900. Also after I updated my gpu bios i can't download any more drivers.
    Reply to jamie.calmeyn
  12. You got any friend with a good PSU you can test your card on? Otherwise your card might be broken from the beginning, that is way too low and with just the simplest of drivers, you should be doing much better. And I hope you have the card inserted in the right slots.

    For some reason I can't access your motherboard's page right now. Anyway you should consider installing everything on their website just to make sure.
    Reply to Cioby
  13. jamie.calmeyn said:
    Cioby said:
    Did you get the application from your specific manufacturer if you have a custom cooler GPU, like MSI ASUS Gigabyte. Google the 1070 card that you have and check the official site of the company. Go to support or donwload and check any bios updates or apps.

    Also before you installed this card, did you have another card? Did you do a DDU clean install of the new card and remove everything else before installing the new drivers?


    ok. so i instaled the driver and I got 5 more fps in watch dogs on low settings lol


    when fps are that low usually points to cpu thermal throttling


    do you monitor cpu temps while you play?
    Reply to maxalge
  14. jamie.calmeyn said:
    hello everyone I have my Nvidea Gtx 1070 for a year right now. But i never got the performance I expected from it. I searched trough a lot of forums and eventually gave up. Until I recently noticed that my GPU either maxed out at 4 gB vram or didn't do anything(GPU usage below 10%) Does anybody knows how to fix this or give me more fps in games thanks ;)

    watch dogs everything low: 0-20 fps.
    just cause 3: 0-3 fps.
    (in just cause my GPU usage didn't even go up to 4%(in watch dogs my usage went up to 60% but the vram never went higher then 4 gb))
    (also cpu sits at 50% while "gaming")


    hi everyone.
    first of all thanks for all the help. i really appreciate it.
    second: I found the solution.
    the problem was that I had a DVI-d to VGA adapter installed because my monitors work on VGA. So I connected my computer to a TV with a hdmi cable. And everything worked fine, before my fps on watchdogs was about 0-25 fps on low. now my fps (on the tv on a higher resolution) is 150 fps on ULTRA I have tried several other games and my gpu is now performing like it should. thanks for all the help guy's
    Reply to jamie.calmeyn
  15. Hi everyone.
    first of all thanks for all the help. i really appreciate it.
    second: I found the solution.
    the problem was that I had a DVI-d to VGA adapter installed because my monitors work on VGA. So I connected my computer to a TV with a hdmi cable. And everything worked fine, before my fps on watchdogs was about 0-25 fps on low. now my fps (on the tv on a higher resolution) is 150 fps on ULTRA I have tried several other games and my gpu is now performing like it should. thanks for all the help guy's.
    Reply to jamie.calmeyn
  16. maxalge said:
    jamie.calmeyn said:
    Cioby said:
    Did you get the application from your specific manufacturer if you have a custom cooler GPU, like MSI ASUS Gigabyte. Google the 1070 card that you have and check the official site of the company. Go to support or donwload and check any bios updates or apps.

    Also before you installed this card, did you have another card? Did you do a DDU clean install of the new card and remove everything else before installing the new drivers?


    ok. so i instaled the driver and I got 5 more fps in watch dogs on low settings lol


    when fps are that low usually points to cpu thermal throttling


    do you monitor cpu temps while you play?


    No temps are fine. i found out that it was the connection between my monitor and my GPU. thakns for your time tho ;)
    Reply to jamie.calmeyn
Ask a new question Answer

Read More

Gtx GPUs FPS