Speakers out of sync with streaming audio.

As the title states, when I am watching twitch, youtube, etc. the audio will progressively get more out of sync the longer I watch a video/stream. What is strange though is when I switch to my headphones, audio is fine. Then when I switch back to my speakers, it's all good again. Though the audio will still get out of sync.

I have tried to use different audio jacks on the motherboard and it didn't change anything. If it is a speaker problem, that wouldn't be too big of a deal because it's just a set of cheap speakers :P

If the speakers are the potential problem, any recommendations for speakers? (nothing too crazy expensive, no more than $30)
Reply to SoulXD
4 answers Last reply
More about speakers sync streaming audio
  1. What browser are you using? If Chrome try enabling or disabling hardware acceleration under advanced settings.

    The reason I assume Chrome is that I am having the same issue. I had acceleration turned off and the desync was out of control. With it on, it is working correctly, for now.

    You can also test this by using a different browser for a while and see if it occurs across them as well.

    Here is another thread with the Chrome issue: http://www.tomsguide.com/answers/id-3538515/youtube-hardware-acceleration.html
    Reply to SinxarKnights
  2. How are your speakers and headphones connected to your PC?
    Reply to TJ Hooker
  3. SinxarKnights said:
    What browser are you using? If Chrome try enabling or disabling hardware acceleration under advanced settings.

    The reason I assume Chrome is that I am having the same issue. I had acceleration turned off and the desync was out of control. With it on, it is working correctly, for now.

    You can also test this by using a different browser for a while and see if it occurs across them as well.


    I am using chrome and have already tried disabling hardware acceleration :( Just tried Edge and still having the same issue.

    Anonymous said:
    How are your speakers and headphones connected to your PC?


    Speakers are 3.5mm and headphones are usb
    Reply to SoulXD
  4. Hi,

    I am also having the same issue, from what i can remember it started when the new NVIDIA graphics drivers got released.
    Have tried all the suggestions above as well as re-installing both graphics and audio drivers with no success.
    I will be watching a YouTube video, Twitch stream, Netflix, pretty much any platform and this problem will happen.
    Slowly the video will start to lag a few seconds behind the audio and progressively get worse, refreshing the page restarts this loop.
    After reinstalling my drivers the problem went away for a few days then returned.
    Now if i try to do the same fix it will not work.
    Any suggestions would be much appreciated,
    Kind regards.
    Reply to triple_six
Ask a new question Answer

Read More

Streaming Speakers Audio