Windows 7 DVD Install Freeze ASRock x370 Killer SLI + Ryzen

Hi all -
I am trying to install Windows 7 Home Premium 64-bit on my new system using a retail DVD copy of Windows 7. However, when attempting to boot from DVD, the system freezes, requiring a reboot. (This seems to be a common issue with my motherboard/chip combination. Most people freeze at or after the "loading files" part of the install, but I don't even get that far. As soon as the system starts reading the DVD, it just freezes on a black screen with a single little cursor line in the middle.) The DVD is a brand new retail copy - bought it a few years ago, but never updated my old system with it, so I just opened it today. It will run from within Windows 10. (My system was supposed to come with a formatted HDD only, but my system builder apparently left their test copy of Windows 10 on there after setting everything up.) So, the Windows 7 DVD and DVD drive seem to be working and okay. However, I want to do a clean install with new partitions, etc. For that I need to boot from DVD.

I have read about Installing Windows 7 on AMD AM4 chipsets under the ASRock support information for myASRock x370 Killer SLI motherboard as detailed at this link: ASRock x370 and Windows 7

The support information states that "Intel® N3000 Series SoC, 100 / 200 Series and AMD AM4 chipset has removed their support for the Enhanced Host Controller Interface, so you might find it difficult to install windows7 operation system Since the USB ports won't work.
Please refer to the Web page from following to install Windows7 on AM4 platform mothebroards."

The support information that follows, and numerous websites, seem to indicate this freeze is a USB issue, and that I shouldn't have problems if I use a PS/2 mouse and keyboard, along with an optical drive. However, I swapped out for a PS/s mouse and keyboard and am still encountering the same freeze.

ASRock support also talks about enabling PS/2 Simulator under BIOS\Advanced\USB Configuration if you're using any USB devices. I figured maybe it would help, even though I'm using PS/2 devices. Many people seem to need to put their BIOS in some type of legacy mode to get Windows 7 to install. However, I cannot try this as my version of the BIOS (P2.10) does not have the PS/2 Simulator mode available. In fact there are no USB Configuration options in my BIOS\Advanced tab at all. I guess my system builder updated the BIOS and lost the version that had that option or more recently produced boards come with the newer BIOS version. And there doesn't seem to be any way to rollback the BIOS as ASRock doesn't post older versions online. OR, I may need to update to a newer version of the BIOS. The instant update thingy gives me an internet connection error, though I'm connected, so I'd have to do it manually, and I don't know how.

Any thoughts on getting this to work? ASRock support does have a "Win 7 USB Patcher" that allows installation from USB (see the "With a USB drive and any kind of mouse or keyboard" option at the support link above. But I'm highly confused about the whole thing. I don't understand anything about making bootable USBs from .iso files and then patching them. That all seems pretty ridiculous since I have a perfectly fine DVD right here! And I'm using the PS/2 mouse and keyboard. So... no idea why it's still freezing.

My system specs:
CPU - AMD Ryzen 5 1600x 3.6
MOTHERBOARD - ASRock X370 Killer SLI AM4 ATX
HDD - 500 GB WD Blue SSD 2.5" SATAIII
RAM - 8 GB DDR4-2400
DVD - LG 24x DVDRW
POWER - Corsair CX650M 80 Plus 650W
VIDEO - NVIDIA GeForce GTX 1050 Ti 4 GB
MONITOR - LG 24" 24MC57HQ-P IPS Widescreen Gaming Monitor
MOUSE - currently Logitech PS/2, but will eventually use a wireless USB mouse
KEYBOARD - currently Logitech PS/2, but will eventually use a USB keyboard.

I really want to go with Windows 7 - it's the oldest system allowed for a couple of my games. However I also have games that won't run under 7, so I was hoping to dual-boot Windows 7 and XP. But it looks like my hardware is making that all but impossible. I don't want to run Windows 10; it's more like a virus than an OS!

I hate to spend more money on this, but right now I have a useless brand new system. All I can do is boot into my unregisterable copy of Windows 10, which just makes me cry. Soo... would there perhaps be a different motherboard that would support my other hardware as listed above and allow me to run Windows 7 (and XP, ideally)?

Or would my config run Linux? No experience with it, but maybe it's about time to try it.

Any ideas? Please give me the "For Dummies" version. Hardware technology has changed a bit from my last systems. My system that just died was almost 10 years old, but still mostly capable of meeting my needs because it was built to last, so I haven't had to deal with any new tech in a while. I'm totally lost on EHCI and UEFI and .iso files and USBs. I'm used to just installing XP from CDs! (I had XP on my secondary PC, Vista on my Primary PC, and I have Win7 on my laptop.)

Thanks much - RR
Reply to oredraven
6 answers Last reply
More about windows dvd install freeze asrock x370 killer sli ryzen
  1. Yes. it's difficult to install W7 on those new systems, specially if an older version. You need to preinstall drivers for MB, chipset and USB. XP is definitely out of question.
    Reply to CountMike
  2. Thanks CountMike - I could use some help on exactly how to pre-install drivers and such. It looks like I need to add them into my Windows install, from what I've been able to understand from other posts about this. And that means using the Windows 7 .iso and adding them in, instead of using the DVD, I think. I could use some step-by-step instructions, as I'm kinda lost with all I've read.

    Thanks - RR
    Reply to oredraven
  3. Aha, thank you, Mike. That helps a bit. Although ASRock support said an install from optical drive with PS/2 devices should be fine, it clearly wasn't working. So, I figured I'd try installing from USB with patch(es). I tried downloading the Win 7 .iso and using the ASRock Windows 7 USB patcher, but unfortunately it goes into "unpacking files from .iso" (or something like that) and just hangs out there forever. The progress dot keeps going, so it's not a total freeze, but it doesn't seem to want to finish. I tried both the main release and beta and let each of them run for like 45 min. I called ASRock and they said basically "Yeah, they work for some people and not others." (That makes no sense, but... okaaay.) Unfortunately, they don't seem to have the drivers available in a standalone format. I'll have to call them again and see if they have them in standalone format somewhere.

    Meanwhile, I have gotten Windows 10 going temporarily (my own copy, not the one my system builder left in place), just because I wanted something to work with to check out the system and make sure that my issues were Windows 7 issues and not hardware issues. I also got Linux Ubuntu going; didn't like that distro, but I think Mint may be okay. I'll play with it later, though I'd rather not have to switch to a totally new OS style.

    So, still looking for thoughts on getting Windows 7 going on my system, if anyone else has any more specific instruction on exactly what needs to be patched and how to do so.

    Thanks = RR
    Reply to oredraven
  4. ASRock x370 Killer SLI

    Specifications:
    OS - Microsoft® Windows® 10 64-bit*
    *For the updated Windows® 10 driver, please visit ASRock's website for details.

    As you can see Windows 7 is not a supported OS. If you want to pursue that route:
    How To Get Ryzen Working on Windows 7 x64
    https://www.anandtech.com/show/11182/how-to-get-ryzen-working-on-windows-7-x64
    Reply to Calvin7
  5. Thanks Calvin7 - Yeah, unfortunately I didn't realize the world was being so... "encouraged" to use Windows 10 when I configured my system. However, according to both the article you linked and ASRock's support, I should be fine as long as I use a PS/2 mouse and keyboard during Windows 7 install. I'm doing that and it locks at the black screen once it starts reading the DVD. However, I'm starting to think it may not be a Windows 7 issue per-se. I get the same lock when I try to do anything other than load from Windows Boot Manager. If I set my SSD (with Windows 10 installed currently) as the first boot device, it locks the same way. I'm guessing I could put a Windows 10 DVD in the drive and it would still lock. The system will boot from USB; that's how I installed Windows 10 and Ubuntu. But, of course, it won't boot from Windows 7 on USB, unless the Windows 7 USB is patched with the USB drivers. ASRock has a patcher to do that, but it's not working for me.

    So, it seems like the issue is more that the system won't boot from either physical drive - SSD or DVD. Any thoughts?

    Thanks - RR
    Reply to oredraven
Ask a new question Answer

Read More

Windows 7 ASrock