Stuffed up 2 ssd's and don't know how to fix - raid perhaps? Not sure...

I had 2 x 250Gb ssd's set up in my desktop PC running Windows 7 ultimate 64 bit. At no stage did I set them up in raid, but I did have the OS on one drive and all the widows documents on the other.

I lost the OS on the ssd so I decided to just reformat and reinstall Windows. I used a sata to usb connector to hook the drive up to my windows 10 laptop and formatted the drive through disk manager. The drive formatted ok (ntfs) and showed 238Gb.

I put the drive back in the PC by itself (disk 0. Only other drive was dvd) and tried to install windows 7 again. When it got to which drive to install to, it showed 2 entries for disk 0. One was "partition 1 - 238Gb", the other said "unallocated space - 256Gb".

It would not let me install windows 7 on either one.

Thinking it may be the ssd with the problem, I removed it and attached the second ssd instead. It came up with similar entries, only reversed and also would not install windows.

Has anyone seen this issue before and if so, how can I fix it?
Reply to ianc13
5 answers Last reply
More about stuffed ssd fix raid
  1. Try this....

    Connect one of your SSDs
    Boot from your Windows 7 DVD.
    When you get the to the install screen press shift-F10. (Progress to the point where it says "install now"

    This will bring up a command prompt. Type diskpart and press enter
    Type list disk. You should see your SSD and DVD or USB (Depending on which you're installing from).
    Take note of the disk number of your SSD (Usually 0 when it's the only drive in the system)
    Type select disk X (Where X=the number your took note of in the previous step), and press Enter
    Type Clean and press enter.
    You should get a response that the disk clean has completed successfully.
    Type Exit and press Enter
    Type Exit and Press Enter
    Resume your Windows installation. Select the Customize Installation
    You should see your SSD. On the bottom right click New
    It should allocate all space by default, and when you click next it may say it's going to create additional partitions. Just accept and continue the install.

    Good luck!
    Reply to Tanyac
  2. Thanks Tanyac, I tried that but all it did was combined the previous parttition 1 and unallocated space into 488Gb unallocated space (drive 1) and 512Gb unallocated space (drive 2). Neither of them would successfully format for the windows setup.

    Drive 1 would appear to have a hidden partition on it, but I have not been able to find it in either the diskpart or in disk manager when hooked up to my laptop.

    Excuse the delay i answering, I am in Australia and work nightshift so only just woke up a little while ago (9:36am here atm). Cheers

    Edit: I also tried using the ssd secure erase in the bios (Asus Maximus IV MB) which ran ok. Drive one came up as 488Gb, drive 2 came up as 256Gb initially but 512Gb after the secure erase.
    Reply to ianc13
  3. Clean should remove all partitions and set the drive as uninitialized.

    After selecting a disk in diskpart, what do you see on Drive 1 if you then type list partition?

    These are SATA drives, yes? And your BIOS is set to AHCI mode, right?

    Ok, so what about this... (It has worked for me in the past on stubborn drives).

    select disk x
    clean
    convert gpt
    create partition primary
    format fs=ntfs quick
    assign letter=C
    active

    Then try install windows

    if you don't want to use the whole drive add size=xxxx to the create partition command

    I'm in Australia too.
    Reply to Tanyac
  4. Hey Tanyac,

    All drives are in ahci and they are sata ssd drives. I don't think the problem is with the hard drives now, but rather with slot 0 and slot 1 sata modules. I connected another ssd I had to slot 0, and it did the same thing. When I connected it to slot 2 however I was able to install windows without an issue.

    I tried to connect the former ssd to slot 0 after windows was up and running (on slot 2) and it said I had to initialise the drive. I did this and it then said to format it, which I attempted. The format failed. I then looked at disk manager and the drive comes up as 488Gb. If I try to format it as a simple volume there, it says the partition will be 502Gb.

    I cannot work out why it is doing this! Very frustrating....

    Mother board is actually a Asus ROG Maximus VI extreme and has 10 sata slots with 2 different controllers. Slots 0 to 5 are on one, slots 6 to 9 are on the other. The problem only seems to happen on slot 0 and 2.

    Where in Aus are you? Am in SA here.
    Reply to ianc13
  5. Sorry, this new Tom's website seems to regularly suffer from memory loss, hence the delay in responding.
    I am in Melbourne, but was Born and raised in the Berri area in the Riverland in SA.

    That is indeed bizarre. That's a Z87 board, right?

    I guess you've done all the things like update to latest BIOS? Or re-flash it to the latest if already on the latest (or at least Clear CMOS and make any necessary changes)??

    So, if you put both drive on ports 1 and 3, or on the put them on the ASMedia controller they both work as expected?

    Not the first time I've heard of issues with ASUS's chipset. I had 2 X99 deluxe motherboards and had issues. Several customers of mine also had similar issues. In my case, on port 0 the SSD would not bott reliably, and I had to do a BIOS reset just to get it to boot.

    If these two ports consistently fail then it sounds like either chipset or motherboard. Neither of which is helpful. I'm guessing the board is out of warranty?
    Reply to Tanyac
Ask a new question Answer

Read More

SSD NAS / RAID Windows 7